X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Formatting text (bold, italics, etc) in webmail client does not work in Firefox; works in IE and Chrome

Posted

I use the Smarsh webmail client for my company's email service.

I have been using Firefox in the office for quite some time, and only recently has this issue come up.

When composing emails using the Smarsh client, I cannot format text (using bold, italics, or underline) using the buttons built in to the client. When I highlight text and click a formatting button, the cursor just moves to the end of the line.

Using keyboard shortcuts to edit the formatting works sometimes, but is sporadic (sometimes formatting PREVIOUSLY selected text but not the currently selected text).

I have tried downgrading to Firefox 16, 17, and 18 (as this problem has only come up in the last couple of weeks, and Firefox 19 was release I believe on 2/13), but this did not solve the problem either.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • ActiveTouch General Plugin Container Version 105
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • McAfee ScriptScan for Firefox 14.4.1 ({D19CA586-DD6C-4a0a-96F8-14644F340D60})
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) G35 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2982
  • adapterDeviceID2:
  • adapterDrivers: igxprd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'6.14.10.5218']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 12-19-2007
  • driverDate2:
  • driverVersion: 6.14.10.4906
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.14.10.5218']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.14.10.5218']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • browser.urlbar.autocomplete.enabled: False
  • extensions.lastAppVersion: 19.0
  • font.internaluseonly.changed: False
  • gfx.blacklist.suggested-driver-version: 6.14.10.5218
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362166796
  • places.history.expiration.transient_current_max_pages: 86972
  • places.history.expiration.transient_optimal_database_size: 139153734
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars
  • Top 10 Contributor
418 solutions 4938 answers

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97052 answers

This may be caused by JavaScript that isn't compatible with the current Firefox version and that needs to be updated by that site.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.