X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Windows 7 service pack 2 and Firfox are now not compatable? Is there a fix?

Posted

Windows 7 updated today. Firefox no longer works. States not compatible. Uninstalled and reloaded. Still no go. Is there a fix for this?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • WildTangent Games App V2 Presence Detector
  • 4.1.10329.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello, there should be no compatibility issues between windows 7 sp1 (there is no sp2 as far as i know) & current versions of firefox whatsoever: https://www.mozilla.org/en-US/firefox/19.0/system-requirements/

what does the error message you get state exactly & in which circumstances is it appearing?

please also always download firefox from its official location: getfirefox.com

notnow 0 solutions 1 answers

Helpful Reply

The answer can be found here from a Microsoft thread (credit to Millie, not myself):

After uninstalling KB2670838 IE9 and Firefox worked again, I then installed IE10 and found that the IE10 installer re-installed KB2670838 and Firefox would crash again but IE10 did not crash.

After some searching, I found the Troubleshooting page at mozilla.org http://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Start Firefox in Safe Mode (hold the shift key when starting Firefox) then turn off hardware acceleration: At the top of the Firefox window, click on the Firefox button and then select Options At the top of the Firefox window, click on the Tools menu and then select Options On the menu bar, click on the Firefox menu and select Preferences...At the top of the Firefox window, click on the Edit menu and select Preferences Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. At the top of the Firefox window, click on the Firefox button and then select Exit At the top of the Firefox window, click on the File menu and then select Exit On the menu bar, click on the Firefox menu and select Quit Firefox At the top of the Firefox window, click on the File menu and select Quit Start Firefox the way you normally do. Firefox does not crash on startup now.

PS This reply was submitted using Firefox.

Posted 2/27/2013 by Millie