X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I see that the bookmarks toolbar is "off" by default. How can I change the default to be "on"?

Posted

In newer versions of FF the bookmarks toolbar is off by default, as described here: https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars?esab=a&as=aaq

I know how to re-enable it manually, which I have to do every single time I start FF. How can I change the default to "on"?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • ActiveTouch General Plugin Container Version 105
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • 4.1.10329.0
  • 1,2,1,2044
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Windows Activation Technologies Plugin for Mozilla
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Grad 6 solutions 51 answers

Just right-click an empty space next to one of your open tabs and select the "bookmarks toolbar".

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Chosen Solution

Hello yyk7789, see : Corrupt localstore.rdf

http://kb.mozillazine.org/Localstore.rdf


thank you

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Which security software (firewall, anti-virus) do you have?

Some security software has virtualization or sandbox features that may cause problems by protecting and restoring files in the Firefox profile folder.

Question owner

Hi, Im using Norton 360 and was even before this happened. It seems that FF changed their default settings. What is the prescribed way to change them back? Your reply suggests that FF will attempt to restart in the same configuration that it was in when it last exited. Is that so?

Question owner

Thanks - I know how to turn it on each time. What I'm trying to discover is how to have FF turn it on (by default) so I don't have to. This was a recent change by them. It used to be defaulted to "on", not "off".

Question owner

Thanks for a reference to the localstore.rdf. Interesting stuff. That said, I should hope that FF wouldn't expect me to have to dive into that area in order to change a default setting. That sound more like Microsoft than Mozilla.

david_winiecki 0 solutions 7 answers

I want my bookmarks toolbar off when I start Firefox. It is always on when I start. I deleted my localstore.rdf, my toolbar was reset, but it still displays the bookmarks toolbar every time I start Firefox. Must be a bug.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
david_winiecki 0 solutions 7 answers

Following those instructions I determined it was an extension. Problem solved. Thank you cor-el!

Question owner

Which extension?