X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Embedded video is black but with audio, but the video works fine on youtube.

Posted

I'm having trouble with firefox not been able to display embedded video on sites. I see the preview image but when i start play all video area becomes black and I can hear the audio playing. I also can pause the "video".

If I start firefox in safe mode, it works. I have deactivated all my extensions/add-ons, without any success. I have reset all cache, no success I have restored to factory result, no success I have uninstalled firefox, and deleting all local data and reinstalled firefox, still same problems.

I have tested to go to http://www.youtube.com/html5 and activated the html5 player, and then I see the play button, progressbar and volume etc, but still no video.

The video is working fine in IE 9 and Chrome (unknown version, but since it autoupdates it's probably the latest)

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Microsoft Lync 2010 Meeting Join Plug-in
  • 5.1.10411.0
  • NPWLPG
  • wpidetector
  • Windows Activation Technologies Plugin for Mozilla
  • Foxit Reader Plug-In For Firefox and Netscape
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/sv-SE/

Extensions

  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Skype Click to Call 6.6.0.11664 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2: NVIDIA NVS 3100M
  • adapterDeviceID: 0x0046
  • adapterDeviceID2: 0x0a6c
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 512
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 8-25-2010
  • driverDate2: 6-27-2010
  • driverVersion: 8.15.10.2202
  • driverVersion2: 8.17.12.5738
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • extensions.lastAppVersion: 19.0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 102018
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Check our the common problem in audio

Helpful Reply

As I wrote, I now have zero extensions but I do have plugins. But as I see they are not disabled when I run in safe mode and in safe mode it works. Also, the video works if I go directly to youtube, but not if I view it embedded/in a iframe.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.


You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin
eyeLOVEmyDUCKS 0 solutions 1 answers

So I unchecked the box: "Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" and the embedded video starting playing VIDEO! Thanks for that. Now I'm curious if it should work however with it clicked though?