X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 19 has become incredibly slow since Windows 7 update of 27/02/2013

Posted

Yesterday, I used Firefox (very recently updated to version 19) and it worked fine. Today, it completely freezes on any page (google.com, internal reset page, upon launch, ...) The only thing which seems to have changed during the night is an automated update of Windows 7 by MicroSoft. I have tried resetting FireFox. => net result: still exactly as completely frozenly slow I have completely uninstalled Firefox and deleted the ...>>Program Files>>Mozilla Firefow directory, then I have reinstalled FireFox from scratch... => net result: absolutely no improvement.

What else can I do to fix FireFox before I give-up and move to Opera for good?

Chosen solution

I was having the same issue today on Windows 8 I turned off all Add-ons but still FF would hang on most pages (facebook, gmail, bbc news) I un-installed Firefox 19.0.1 then installed Firefox 17.0 updated to 19.0.1 turned all Add-ons back on and it all works once more.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Opera/9.80 (Windows NT 6.1; WOW64; Edition Campaign 21) Presto/2.12.388 Version/12.14

More Information

saraneth 1 solutions 7 answers

Uninstalling the update seems to work. I don't know another work around though.

Question owner

Dear Saraneth,

I am not sure I properly understood your answer. You mean "Uninstalling the [Windows 7] update" ?

And when you say "seems to work" you mean that you had the same problem, tried uninstalling the Windows update and it fixed the problem for you, or you're just suggesting I do it and see if it fixes my problem?

In the latter case, I am quite reluctant since the automated Windows 7 update is the only thing I can think happened, but I have no way of guaranteeing that it is the cause of my troubles...

Thanks in advance for your answers to the questions to your answer... And thanks for the original answer.

Cheers, Dom64

saraneth 1 solutions 7 answers

Hey Dom64, yes I had the same problem and uninstalling the update did seem to fix the issue for me (I had the same issue with FF plus some other problems with IE and have read it caused a problem with WLM as well).

There appears to be another work around suggested by madperson which can be found here:

https://support.mozilla.org/en-US/questions/951904

The issue itself seems to be a problem with graphics drivers that have conflicted with the update. Either uninstalling the update or removing hardware acceleration should fix the issue. Though bare in mind removing the hardware acceleration for FF will not help the conflict with other browsers if there are problems with them too.

Hope this helps, let me know how you get on.

Modified by saraneth

Question owner

Thanks 1000 000 Saraneth. Disabling hardware acceleration for FireFox graphics (as described in [https://support.mozilla.org/en-US/que.../951904]) fixed the problem. Let's hope that a later upgrade of Windows 7 or a workaround in the next version of FireFox fixes the core of the problem...

Once again, thanks 1000000 Dom64

trefork 0 solutions 2 answers

DELETED: I posted wrong information.

Modified by trefork

Question owner

Trefork,

what do you mean with your laconic (and highly non-helpful, non-useful) "Wrong information"? Which information is wrong? The one in the [https://support.mozilla.org/en-US/que.../951904] discussion? The one given by Saraneth in his/her initial (or subsequent) answer(s)? The fact that I actually disabled the hardware acceleration and that it actually fixed my problem?

Or, tautologically is it your "Wrong information." post which is the wrong information?

Cheers, Dom64

trefork 0 solutions 2 answers

Sorry, I meant that what I wrote earlier (before my edit) was wrong, not that anything posted by others was wrong. I'll update to reflect this.

Question owner

Dear Trefork,

I apologise too; I hope I wasn't too aggressive in my answer to your answer...

Cheers, Dom64

Rev.Dr.Jo 1 solutions 2 answers

Chosen Solution

I was having the same issue today on Windows 8 I turned off all Add-ons but still FF would hang on most pages (facebook, gmail, bbc news) I un-installed Firefox 19.0.1 then installed Firefox 17.0 updated to 19.0.1 turned all Add-ons back on and it all works once more.

paulferguson 0 solutions 2 answers

I had this problem also. Firefox was updated to 19.0.2 from 18.0.2 (I always skip the xx.0.0 release and wait for the inevitable update within a week to xx.0.[1|2]) at the same time as installing the March Windows update patch batch.

Firefox 19 would start fine, but within about 24 hours it would near enough grind to a halt even though other programs and the system continued to have a snappy response. New FF windows would take 10 seconds or so to appear, where before they would appear almost instantly. Scrolling/tabs would also run slowly. I tried disabling hardware acceleration, as mentioned in this thread, but that didn't resolve the problem for me.

I have Windows 7 running on an Intel i7-960 (3.2GHz with 4 hyper threaded cores) with 12 GB RAM so plenty of resources. The only way to cure it was to close and restart Firefox. I do have a lot of windows/tabs open, but this wasn't an issue before FF 19. Add-ons are limited to Ad-block plus, flash block, Adobe Flash.

I have done half of the solution proposed by Rev.Dr.Jo and down graded to Firefox 17.0.1. It wasn't immediately obvious where to get the older version from but I did track down the Mozilla FTP site here for anyone who hasn't found it yet: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/

I haven't updated back to Firefox 19.0.2 yet - I'm waiting for Mozilla to fix the problem properly before I risk updating and the problem coming back.

Hope this helps P

paulferguson 0 solutions 2 answers

Helpful Reply

An update of my experience on this issue for anyone still following it.

After going back to 17.0.1 I got repeated nag pop-ups (at least once a day) telling me to update to 19.0.2 which I ignored, and never gave permission to Firefox to perform the update. For as long as those popups were appearing my Firefox experience was back to being smooth and snappy.

Then about 5 days ago the pop-ups stopped (but help|about still reported version 17.0.1), and about the same time Firefox started getting slow again. It was as if it had updated to 19.0.2 and started experiencing the slow downs that version brought without actually admitting it had updated.

To see if it had updated I did an update from help|about (still reporting 17.0.1) and it downloaded+installed version 20.0.0 which also exhibited the slow down problem. So I uninstalled and reinstalled the 17.0.1 that had been fine previously. It still exhibited the slow down problem, where before it hadn't. I am using 17.0.1 to write this - when it was started it was fine, but only two hours after I started FF, it is now like swimming in treacle.

To eliminate one possibility I updated my nVidia drivers from 310.90 (Jan 2013) to 314.22, but still no improvement.

I have no problems with other programs running slowly. Firefox in this state is now mostly unusable. Having to restart the program every two hours or so isn't a practical work around.

Modified by paulferguson

Rev.Dr.Jo 1 solutions 2 answers

I eventually worked out that my problem was due to the way I had configured Windows 8, as I wanted to to boot to the desktop I had set-up a job to run from the scheduler to start explorer, removing this job and installing "Classic Shell" stopped the problems that FF was having and makes the PC boot to the desktop, as-well as returning some of the functionality of windows Microsoft had removed in Win8.