X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 19 not working with MSN homepage keeps crashing, Msn homepage works with IE 9 though?

Posted

I have always set MSN as my homepage with all versions of Firefox. Firefox suddenly stopped working (crashed 3 days ago). I had been running Firefox 19 for a few days with no issues, just stopped working with MSN and the screen just froze? I tried MSN with Internet Explorer and had no issues? I tried disabling the plug ins and Java, but no use? The only way I can use Firefox is to use a different homepage, then there are no problems.

Chosen solution

iceman21, thanks for posting back. Glad you solved your problem.

I do suspect something may have changed but as yet I have not discovered what any relevant change may have been. One way or another most users seem able to resolve the issue, usually by clearing cookies and the cache.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Foxit Reader Plug-In For Firefox and Netscape
  • NPWLPG
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Try in safe mode

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.
_________________________________________________________________________________
We're sorry to hear that your Firefox seems to be crashing. Please perform the following steps to give us a crash report ID that helps us find out more about the cause of the crash.

  1. Enter about:crashes in the Firefox location bar (that's where you enter your website names) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the most recent 5 report IDs that you see in the crash report window and paste them into your forum response.

Thanks in advance for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Question owner

Hi, thank you for your input, I have started Firefox in safe mode as suggested and went to the MSN site and it did not crash (which it did before!) I then set the MSN as my homepage and restarted Firefox and guess what? It worked, I could not believe it, there is no logical reason to explain that, but it works. For information prior to your suggestion of using safe mode I had done the following: 1. Uninstalled and reinstalled Firefox. 2. Disabled all plug ins and Java. 3. Had to use a blank page to get it to load and then I could use any site for my homepage, but for MSN.

I am an advanced user of computers and software and can usually sort things out, but this was most strange and I cannot find an explanation for it, but it is working now after 3 days of efforts and frustrations, my thanks to all and hope you can make some sense of this!

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Its problem with your addons, remove your unwanted plugins/extension

Question owner

Hi iamjayumars, you would think so and that would make perfect sense to me, but all I did was to start Firefox in safe mode as you rightly suggested and then restart it normally and all was okay, very strange issue. I have not removed anything at all, have changed nothing, but it now all works after 3 days?

I don`t know if you use MSN, but they use the background of their page for advertising, by coincidence I notice that there is no advertising today, the graphics have been removed, could be something strange there which may have caused a problem, might be wrong but who knows. If the problem does come back then will do as you say and remove the add ons one by one and let you know. Many thanks for your much appreciated help.

RayGo 0 solutions 4 answers

I'm having a similar problem loading msn.com as my homepage. Actually, I can't get msn.com to load at all with Firefox 19. It does not crash but I just get a blank window. I tried using safemode as suggested but that does not work either, just the blank screen. This problem started about the same time as iceman21 around 2/25/13. MSN will load under IE.

Any suggestions?

RayGo 0 solutions 4 answers

Helpful Reply

I fixed the problem by removing all cookies as suggested in another similar post. Thanks.

Question owner

Hi RayGo, Thank you for letting me know, I thought that first of all it was me getting sillier as I get older! I still think that as I said in my last posting that I believe the back ground graphics (buggy) with the MSN advertising had something to do with it. I would wager that you can now enable your cookies again and you will find that you have no problem. It would be interesting to know how you get on if you do this.

RayGo 0 solutions 4 answers

Helpful Reply

msn.com is my homepage and is now running normally. All I did was to Remove All my Cookies and clear my Cached Web Content. I did both operations before restarting Firefox so I'm not sure if one or both were necessary to clear up the problem. I did not disable cookies and I have cookies again. Hope that helps.

Question owner

Ah yes of course you removed them, mistake on my part. Yes, maybe that was there answer to your problem, I did none of that. I only know that the problem vanished when the MSN background advert changed. I have not had the problem since, strange one, but we will see. Thank you for your input however, will bear it in mind if the problem reoccurs.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8025 answers

There have been quite a few posts about this recently.

Anyone with actual crashes needs to post the CrashIDs in their own thread.

If it is a blank page or unable to login that is covered in other threads. Maybe something changed with the site and how cookies and adverts are handled. I suppose it could also relate to the scripts used and Firefox's new javascript compiler.

Question owner

Hi John99, I consider that your comments relating to how the site handled the cookies and adverts summed up the problem perfectly. I can only add that I have used all issues of Firefox from the beginning and this could be described in my case as a 'one off'! Thanks for your help.

cwilson132 0 solutions 1 answers

I did this on my MAC yesterday. I had the same problem today. Anyone else running FF 19 and MAC 10.6.8 with this issue?

Question owner

Hi cwilson132 have you tried setting your homepage as a 'blank page'? Try that and see if it works then.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8025 answers

Chosen Solution

iceman21, thanks for posting back. Glad you solved your problem.

I do suspect something may have changed but as yet I have not discovered what any relevant change may have been. One way or another most users seem able to resolve the issue, usually by clearing cookies and the cache.

exstreamliners 0 solutions 1 answers

Try this new url for msn.com homepage:

http://www.msn.com/?OCID=media_redirect

Hope it helps. God's blessings,