X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Search and Address bar not working.

Posted

Hello, I have this problem were whenever I try to type in something into the search or addresys bars, nothing happens. It's like the enter key isn't working. There is not usual picture next to the search bar (the one that shows you what search engine you're using. If it's google it shows a "g" next to the bar). Instead there is just a picture of a blank page as a placeholder. When I try to go in and add a new search engine by managing the search engine list, there is no option to add a new search engine. I have already tried going into the firefox folder on my computer and deleted the formhistory.sqlite file that is the supposed problem. No avail. I have even gone so far to delete and reinstall firefox to my computer. Well, that didn't work either. So I waited until the next update to see if my problem would be fixed THEN. I am currently on firefox 19.0, which is, as of writing, the most current version. I have tried restarting firefox with all addons removed. And for good measure, I deleted anything that ended with ".sqlite" in my firefox folder. I have tried to get the the about:config menu but do not know how considering how my address bar refuses to search. The greatest thing is that my address bar can still remember all the sites I've typed into it before, but for some unknown reason, cannot take me to any of them! I really don't know what to do next. I can only suppose that I could try completely deleting everything firefox has stored on my computer, as I don't know if just uninstalling the program actually did that. Other then my search bar problem, firefox has been acting fairly normally besides a few minor hiccups here and there. I am trying to remember if I downloaded anything before my search bar problems started or not, but it is always a possibility. I did download the firefox beta for windows 8 metro mode but I can't remember if that was before or after firefox started acting up. It's possible considering that softonic thought they were being really nice by including fbdownloader for free with my firefox metro browser. I am now no longer using softonic ever again. But that's all the evidence I can think up right off the tip of my head. Sorry if this was kinda long, and if any of my description isn't clear or make sense please ask and I can try to verify. Also, if I haven't said this already, my search bar is only not working in firefox. Chrome, Internet Explorer, and Safari are all working fine. Just my luck, I guess. If anyone could help me out, I'd be much obliged. Not being able to use the address bar has been really inefficient. Thank you.

Additional System Details

Installed Plug-ins

  • iTunes Detector Plug-in
  • npsitesafety
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • McAfee MSC FF plugin DLL
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Here is all the necessary system information. If anything else is needed, just ask. However, I think this will suffice.
Firefox Version: 19.0
Operating System: Windows 8
Installed Plugins:
* iTunes Detector Plug-in
* npsitesafety
* Google Update
* Adobe PDF Plug-In For Firefox and Netscape 11.0.02
* Shockwave Flash 11.6 r602
* Next Generation Java Plug-in 10.13.2 for Mozilla browsers
* NPRuntime Script Plug-in Library for Java(TM) Deploy
* McAfee MSC FF plugin DLL
* Intel web components for Intel® Identity Protection Technology
* Intel web components updater - Installs and updates the Intel web components

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  1. Enter about:config in the Firefox location bar and press Enter.
  2. You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  3. In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  4. Right-click on the keyword.URL setting and select Reset from the dropdown menu.

Now you're done. Please report back if this fixes your problem. Thanks in advance!

You can find more information about the Location bar search feature in the Search the web from the Address Bar article.

Question owner

I was able to get to the about:config menu and find the keyword.URL file. However, when I right click on it, the option to reset is greyed out. I am unable to click it. After a bit of experimenting I was able to figure out that I must need a value attached to the file. The spot under value is left blank. So is there supposed to be a value there? Do you know the way this keyword.URL file should be looking? I'll include all the information displayed as well as include a screenshot to show you. Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

You can check if you still have the XML files of the default search engines in the searchplugins folder in the Firefox program folder.
If not then you need to reinstall Firefox.

Try to delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder.


Do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox. If there are problems with updating then best is to download the full version of the Firefox installer.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


CraigVSAMN 0 solutions 2 answers

I seek to delte this reply.

Modified by CraigVSAMN

churlish 0 solutions 1 answers

Jeez, folks!!

Try something easy before firing up the backhoe and carving up your freakin' hard drive!

After looking at all these crazy attempts to fix this, I looked at the Error Console (under Help-About/Web Developer), saw some errors, didn't understand sh?t about what I was doing, then I decided that maybe one of those damned, but helpful Add-Ons or Extensions might be the problem.

Soooooo, not so long story very short, I killed off Ad-Block (actually, just disabled it) and voila!! My freakin' Address Bar works the way it used to!

Yay!!

moderator deleted image - not related to Firefox support

Modified by the-edmeister

drunkard100 0 solutions 1 answers

Worked Great iamjayakumars! My keyword.URL had some yahoo string in it that was holding things up. This had been pissing me off for a while, and kept me resorting to Chrome in some instances...Thanks a ton!

tecsi 0 solutions 2 answers

I have to switch to Chrome or IE to even post this comment. FF 21 is broken--having a non-functional address bar is like a car without wheels.

poiscer 0 solutions 2 answers

Helpful Reply

This is the solution I got:

on:

-please follow these steps:

1. Enter about:config in the Firefox location bar and press Enter.

   You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.

2 In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold. 3 Right-click on the keyword.URL setting and select MODIFY from the dropdown menu. enter your favorite search engine In my case I entered https://www.google.com/search?q=

And that was a super fix for more cool stuffs like website Alexa ranking

Modified by poiscer

segrogan 0 solutions 1 answers

The about config worked well for me. I had a download corrupt firefox and my security package today. I had to reinstall Kaspersky to fix that with no problems, Firefox was redirecting to yahoo pages and the location bar would not accept searches--saying that it is not a proper URL address. I reinstalled Firefox and uninstalled AVGisearch which hadn't been there before. Uninstalling the AVG evidently left the setting blank. So this worked and I think I am back in shape. Have to check if my cross script is working correctly.

Thanks for this help with the searching. Susan

FirefoxGoogleFix 0 solutions 12 answers

Search for configuration key, keyword.URL and highlight it

Right Click on the configuration key, keyword.URL and choose RESET from the shortcut menu.

Firefox automatically resets the value to:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

5. If the RESET option is greyed out in the shortcut options, select NEW and type in the google search location

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

and press OK.

Also return to the Firefox Drop Down Menu.

Select Options (Under Add-Ons), Sub Menu Options. Click on the EXCEPTIONS Button and Clear the Default Add-on sites Firefox has loaded.

Your Firefox Google Search function will now work again, and you are back in business searching using Firefox Google.

..... Easy Fix.

.... Enjoy.

Cheryl

FirefoxGoogleFix 0 solutions 12 answers

Please NOTE: You need to go to the Security TAB as per below:

Also return to the Firefox Drop Down Menu.

Select Options (Under Add-Ons), Sub Menu Options, SECURITY TAB. Click on the EXCEPTIONS Button and Clear the Default Add-on sites Firefox has loaded.

Your Firefox Google Search function will now work again, and you are back in business searching using Firefox Google.

bruce24 0 solutions 12 answers

Moderator removed link that references paid software that users may not necessarily need.

Here is a removal method:

  uninstall softonic toolbar or program in your control panel and browsers extension manager. 
  Eliminate relevant system32 files or exes you recently installed and fix registry key issues.

Below is a softonic removal guide if these are too complicated to you:

Modified by Shawn