X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Personas not working after latest FF update

Posted

Today Mozilla updated me automatically to the latest beta of FF 20, and now the personas feature won't work at all with any persona. Before posting this I made sure the Personas Plus add-on was installed and enabled, which it is. What's going on?

Chosen solution

Did you check the value of this pref?

  • browser.link.open_newwindow.override.external

If it has the default value (-1) then browser.link.open_newwindow is used.


In case you are using "Clear history when Firefox closes":

  • do not clear the "Site Preferences"

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • The plugin allows you to have a better experience with Microsoft Lync
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96695 answers

Does it work without the Persona Plus extension?

That extension is only needed for specific features and not for installing a persona (theme).

If you use a custom theme then try the default theme.

Question owner

Before the automatic installer put in FF 20ß1, personas were displaying perfectly. The Personas Plus add-on was installed and still is, and it shows no compatibility problems. However, all you see is a light purple background and no personas or themes anywhere.

I'm also noticing 2 more bugs:

(1) It does not save exceptions to sites that install add-ons or anything similar

(2) hyperlinks from outside programs are opening in new windows despite being set to open in the current tab.

I must state emphatically that FF 19ß6 and before did NOT have these issues. These are clearly bugs in FF 20ß1

MOZILLA - YOU LISTENING??

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96695 answers

Chosen Solution

Did you check the value of this pref?

  • browser.link.open_newwindow.override.external

If it has the default value (-1) then browser.link.open_newwindow is used.


In case you are using "Clear history when Firefox closes":

  • do not clear the "Site Preferences"

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Modified by cor-el

Question owner

You're correct on both the above counts. You said if the newwindow.override was set to -1, this was causing the problem. What you didn't say was what number to change it to. I tried +1 and it worked. :-) Thanks for the information on the other one, I didn't know you could configure private browsing.

Now please find me a solution for the personas issue until ß2 is released. :-)

James
  • Top 25 Contributor
  • Moderator
437 solutions 3146 answers

You were only updated to 20.0b1 because you were on the Beta testing channel due to using the 19.0b6 and not 19.0 release.

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96695 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Yes, I'm on the beta channel. I've used FF forever and a friend suggested it.

Guess what. Yesterday I closed the browser for several hours and when I turned it back on the personas came back all by themselves - I didn't do anything. I'm wondering if maybe it has something to do with the fact that after applying the tweaks you suggested, I put getpersonas.com as an exception in the security portion of the options menu. The only thing wrong with this possibility is that I never visited the site. I have no other possible explanation for why it's working OK now.

th3guy 0 solutions 2 answers

Helpful Reply

Ok so I really need help and this is getting annoying. The other day I was on firefox, everything was fine, had my nice persona theme on it, then i exited firefox, went back into it a few minutes later only to find that it had to be update(thats fine with me) but to my surprise my persona was not showing up. So I thought ok maybe i just have to go find the theme again and wear it again. Well that didnt work so I tried a few different themes and same result. It said i was wearing it but no change to the appearance. So I came here looking for help. From what I'm reading in this post, which is the only post that is exactly my problem, I had not a dam clue what the solution is.

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96695 answers

Helpful Reply

If you are in Private Browsing mode then the persona is disabled in Firefox 20 and later and you get the default theme and a possible purple PB icon on the tab bar and a "(Private Browsing)" appended to the title bar if visible.

th3guy 0 solutions 2 answers

That was the problem. It did say (private browsing) at the top. I disabled it and now my persona shows up. Thank you so much for the help XD

matt312 0 solutions 1 answers

Hi, I still have the problem that with V20 the personas rotator is not working. When I click on 'Rotate next' it prompts me to install Personas Plus, but this is already installed and enabled. Nevertheless it always asks me to install it. And no new persona is rotated.

Can anybody help me out?

Best regards, Matt

jellinn 0 solutions 1 answers

same issue as matt312. this update has given me several hours of hassle so far.

  • personas not working
  • persona rotator repeatedly prompts to install personas plus
  • xfinity player not playing due to a flash error, but flash is updated and working, Chrome is working
  • firefox sync will not sync: i synced for first time due these issues, and then when i reinstall firefox there's no option to sync from server. there's no manage account option in the option/sync tab...
  • tabs on bottom option now gone and requires about:config...

Been losing interest in firefox over the past year, ever since they started taking functionality out of the browser and dumbing it down. all Chrome needs is keyworded bookmarks and i switch

Modified by jellinn