X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

On many sites (Bloomberg.com for 1) the ads are overtopping page content (text); I can provide a screen shot. . Is there a fix for this?

Posted

I'm using FF 19.0 on W7.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • Shockwave Flash 11.5 r502
  • Garmin Communicator Plug-In 4.0.4.0
  • Microsoft Lync 2010 Meeting Join Plug-in
  • Amazon MP3 Downloader Plugin 1.0.17
  • GEPlugin
  • 5.1.10411.0
  • Picasa plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello caribbeandreamer, try to clear Cookies & Cache and check it again.

also could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!


thank you

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


If you have increased the minimum font size then try the default setting "none" in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow websites to choose their fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with overlapping text.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Ok, i cleared all cache & cookies, disabled hw acceleration and restarted - no change. I have not changed any of the default font settings. I'll try safemode next.

See attached screenshot...

Question owner

Ok, restarting in safemode prevented the problem. Now how do I pinpoint which addon is causing the problem?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.

Question owner

I don't use Adblock Plus, NoScript or Flash Block but I'll try disabling and reenabling 1 at a time and let you know which one was the culprit.

Thanks for the quick responses!