X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The browser is stuck in native region language and don´t want to change to english.

Posted

Installed a fresh Firefox from your site on a brandnew lenovo t430 with Windows 8. My default region is Iceland, so firefox went straight to Icelandic. I went to preferences and deleted icelandic and put english in the language window. Nothing changes and im still stuck in icelandic.

Chosen solution

hello, the settings in content > languages only apply to the contents on webpages. to change the language of the user interface please download an english version from https://www.mozilla.org/en-US/firefox/all/ and install it on top of your current version.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • VLC media player Web Plugin 2.0.2
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Chosen Solution

hello, the settings in content > languages only apply to the contents on webpages. to change the language of the user interface please download an english version from https://www.mozilla.org/en-US/firefox/all/ and install it on top of your current version.

Question owner

Thank you :) that was it.

B.