X
Tap here to go to the mobile version of the site.

Support Forum

Hi, my search engines won't stay in the order I want them to be since the last update. Help please?

Posted

I basically order them as I use them, but ever since the last update, they shift back to alphabetical order automatically. Which is a tiny bit annoying.

Is it a bug or something that was newly implemented and won't be changed?

Also, yes, when I first noticed, I removed the 'old' search engines and replaced them, just in case it still won't work. I reorder them and when I reboot firefox, they're back to alphabetical.

Thanks for your help!

I basically order them as I use them, but ever since the last update, they shift back to alphabetical order automatically. Which is a tiny bit annoying. Is it a bug or something that was newly implemented and won't be changed? Also, yes, when I first noticed, I removed the 'old' search engines and replaced them, just in case it still won't work. I reorder them and when I reboot firefox, they're back to alphabetical. Thanks for your help!

Chosen solution

If a value has surrounding quotes then it is treated as a String value.
A Boolean pref needs the Boolean true/false value without quotes.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Shockwave Flash 11.5 r502
  • Google Update
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 0.3
  • Uplay PC Plugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • GEPlugin
  • 5.1.10411.0
  • npcplay
  • Plugin for Wacom tablets.
  • Wacom Dynamic Link Library
  • Reader Library Helper Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12505 solutions 115345 answers

Try to delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
Try to delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder. *http://kb.mozillazine.org/Profile_folder_-_Firefox You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder

Question owner

Thanks for this very quick answer, cor-el! It didn't work, unfortunately. I deleted both files, reordered the search engines, stopped FF and started it again, back to alphabetical :( Sorry!

Thanks for this very quick answer, cor-el! It didn't work, unfortunately. I deleted both files, reordered the search engines, stopped FF and started it again, back to alphabetical :( Sorry!
cor-el
  • Top 10 Contributor
  • Moderator
12505 solutions 115345 answers

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Strangely enough, none of this worked... So I just reinstalled it. I'm a bit annoyed by the fact I couldn't find the problem but there you go, it works again. Thanks for your help anyway!

Strangely enough, none of this worked... So I just reinstalled it. I'm a bit annoyed by the fact I couldn't find the problem but there you go, it works again. Thanks for your help anyway!
cor-el
  • Top 10 Contributor
  • Moderator
12505 solutions 115345 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
Moriaki 0 solutions 1 answers

Helpful Reply

Hi.

The problem probably was in incorrect entry in prefs.js. I had the same issue and that was in my config:

user_pref("browser.search.useDBForOrder", "true"); -bad

user_pref("browser.search.useDBForOrder", true); - good

The wrong value set search engines always in alphabetical order. Some plugin responsible for context searching, has change this entry to wrong value.

Hi. The problem probably was in incorrect entry in prefs.js. I had the same issue and that was in my config: user_pref("browser.search.useDBForOrder", '''"true"'''); -bad user_pref("browser.search.useDBForOrder", '''true'''); - good The wrong value set search engines always in alphabetical order. Some plugin responsible for context searching, has change this entry to wrong value.

Modified by Moriaki

cor-el
  • Top 10 Contributor
  • Moderator
12505 solutions 115345 answers

Chosen Solution

If a value has surrounding quotes then it is treated as a String value.
A Boolean pref needs the Boolean true/false value without quotes.

If a value has surrounding quotes then it is treated as a String value.<br /> A Boolean pref needs the Boolean true/false value without quotes.