X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When I start typing the URL, Firfox would give a list of sites I have visited. How do I clean them permanently?

Posted

I've tried Tools > Options > Privacy, Clear all current history. It didn't work!

Do I have to uninstall Firefox and reinstall it again?

I'm using Firefox v19.0 on a Windows 7 Pro 64-bit PC.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • BaiduSetUp Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Nitro PDF Plug-in for Firefox and Chrome
  • 5.1.10411.0
  • Windows Activation Technologies Plugin for Mozilla
  • Yahoo Application State Plugin version 1.0.0.7
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

alco 18 solutions 141 answers

Hi Corsairgt,
as you type into the Location Bar, the default behavior is to display all results from both bookmarked items and your browsing history of visited pages in a drop-down list. (This feature is often called the "Awesome Bar"). You can change Location Bar autocomplete behavior in "Tools -> Options -> Privacy / Location Bar" by selecting one of the options in the "When using the location bar, suggest:" drop-down menu:

  • History and Bookmarks (default) - Displays both visited pages in history and bookmarked items (no filtering)
  • History - Restricts results to visited pages in history
  • Bookmarks - Restricts results to bookmarked items
  • Nothing - No autocomplete results are displayed

Selecting "Nothing" sets the preference browser.urlbar.autocomplete.enabled to false and completely disables Location Bar autocomplete. This also disables inline autocomplete in Firefox 14 and above
For more information look at this article:
Changing autocomplete behavior - Firefox
Please report back!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Use these steps to remove saved (form) data from a drop down list:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.

Question owner

Thanks cor-el, is this deletion permanent? Could I retrieve the history later on?

Deleting the history one by one is very tedious. Is there a way that I could click once and delete the entire history?

Question owner

"You can change Location Bar autocomplete behavior in "Tools -> Options -> Privacy / Location Bar" by selecting one of the options in the "When using the location bar, suggest:" drop-down menu:

   History and Bookmarks (default) - Displays both visited pages in history and bookmarked items (no filtering)
   History - Restricts results to visited pages in history
   Bookmarks - Restricts results to bookmarked items
   Nothing - No autocomplete results are displayed" 


Hi alco,

Selecting "Nothing" means only hiding the browsing history, it doesn't erase the history. Is there a quick way to delete the entire browsing history of Firefox?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

The list of websites that you've opened by typing or pasting the URL in the location bar is more difficult to remove then 'normal' history items (sites that you've visited via a link).

Items that are bookmarked (i.e. have a highlighted star) can only be removed permanently by deleting that bookmark.