X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF started displaying badly formatted or corrupted pages: Why?

Posted

It really more of the formatting. It seems the pages have been coded wrong. Text does not fit into boxes for the text. Some items are behind others. Sometimes the text is huge. A lot of the time the text is squeezed together very closely in bold. The pages seem to work. I have enlarge and made small the pages, that does not correct the problem. I use FF on an iMac, but that is not the problem. This just started in the last couple of months. It does not affect the functioning of the software, just the visual presentation.

Chosen solution

If you have increased the minimum font size then try the default setting "none" in case the current setting is causing problems.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow websites to choose their fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with overlapping text.


You can do a check for corrupted and duplicate fonts and other font issues:

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Version 3.13.2.11592
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6
  • Shockwave Flash 11.1 r102
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

Chosen Solution

If you have increased the minimum font size then try the default setting "none" in case the current setting is causing problems.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow websites to choose their fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with overlapping text.


You can do a check for corrupted and duplicate fonts and other font issues:

Question owner

Thank you for your quick reply and assistance.

I checked all of the preferences in FF. All were set consistent with the information given.

I will follow this problem more closely and see if I can find out the cause.

I am sorry this did not correct the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)