Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox freezes every few seconds even with latest update and pluging


I am Firefox user since its verson2.

I am using windows 7, Firefox was working correctly but few days back when my system engineer installed Symantec end point protection and domain. My Firefox start freezing very frequently (It is not crashing). But it is too irritating to work now.

I want to use same in future. Please help me to resolve the same.


Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0


  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Kamran Mackey 0 solutions 2 answers

Hmm, are you sure you're running Firefox 19? It was released today, if you didn't know that already. I don't see why you would be having issues as I'm using Firefox right now. And, I would recommend you uninstall Symantec End-Point Protection, and use AVG or Avast as Symantec End Point Protection is known for having problems with Firefox. Hope this helps!


 Kamran Mackey

Question owner

Hi, KamranMackey

Actually i am facing the problem since last couple of month, i am very keen to fix the problem, in search i am continuously visiting site to look for solution and update.

Yes i am using version 19, updated an hr back, but still Firefox freezing, as far as Symantec end point concern, I cant change SEP, since its corporate antivirus.

OS Windows 7 Ultimate, Firefox 19.0, Antivirus SEP 11, In corporate Domain

Kindly suggest.

Kamran Mackey 0 solutions 2 answers

Then you're out of luck, You may want to try Firefox for Organizations, go here to visit the site, it may fix your problems with the regular version of Firefox: Firefox for Organizations website. Hope this helps!



Modified by Kamran Mackey

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

No you aren't out of luck, and don't use the Firefox ESR, it's not good for regular users.

Instead, please try to Reset Firefox Reset Firefox – easily fix most problems

Question owner

Dear Kamran,


I am Firefox user since its versio-2, I am at corporate, but not looking for corporate solution... I am using this as individual user. And ESR is not for individual user.


inthatribe 0 solutions 1 answers

Helpful Reply

Cant help but notice there are page after page of people experiencing freezing problems with the latest update of Firefox (V.19), and on each page you have suggested the reset Firefox. I am having this freezing problem SINCE the V.19 update, never before. I have tried all troubleshooting steps to no avail, but am not going to reset and loose all my settings as everyone you have suggested this to in every post said it did not fix the problem. This is quite obviously a problem with V.19 update, please stop advising people to reset their firefox and loose all there settings for nothing, rather advise them of the Mozilla feedback form so Mozilla can fix this v19 problem with an update.

  • Top 10 Contributor
  • Moderator
10776 solutions 96978 answers

Try to disable hardware acceleration in Firefox.

jimflack 0 solutions 2 answers

Helpful Reply

I'm using firefox 20.0.01 - and my pages keep freezing -I've no idea why - its very disconcerting.

  • Top 10 Contributor
  • Moderator
10776 solutions 96978 answers

Hoi jimflack

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
Jedix98 0 solutions 1 answers

I think i may have found a solution to this problem. go to your options and disable javascript, see if that helps!

jimflack 0 solutions 2 answers

I can't recall it freezing since I restarted in Safe Mode - good job!!

SpeedyJDK 0 solutions 2 answers

Jedix98.. HAH. You did it. Javascript was the sinner. This was the entire Firefox/Cyberfox freezing every few seconds. But when i disabled javascript. It runs as a charm. (As long as nothing requires javascript ;( .....) This isn't working out very well. I wonder if there will ever be a fix for this.

  • Top 10 Contributor
  • Moderator
10776 solutions 96978 answers

If it works in Safe Mode and in normal mode with all extensions (Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
Ritoaniajin 0 solutions 1 answers

Hi all,

I am actually having the same problem, but. I noticed that this all happened when I tried to update the Catalyst control center for ASUS. For some reason it failed and the the problems began. So I had to do the System Restore and since then BAM, Firefox started freezing... BTW it work perfectly normally in windows safe mode.

Modified by Ritoaniajin

SpeedyJDK 0 solutions 2 answers

I don't even use Catalyst :) And i got an MSI Motherboard. Just go into Tools/Options and disable Javascript. The problem goes away. Sometimes you can even enable it again shortly and the problem is gone for a while. :)