X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Whenever I click on a google result, it opens a non https google redir link, which evnetually times out, and I need to manually type https,

Posted

Yes, I already read https://support.mozilla.org/es/questions/940508?esab=a&as=aaq but the only answer was not too clear on solving my issue; and I don't know if I can re-reply to the same question and if it will be automatically bumped or not, so I decided to ask a new one with my details.

Could this behaviour be caused by any cyphring protocol on the browser? (excuse my ignorance, I am mostly a computer n00b) or could this be caused by any of my firewall default settings on Windows 7? I checked all such settings and did not find anything blocking FF, but could be some "incoming http" setting on the firewall? I do not know what this means so I decided not to touch anything in case I mess it up.

I also tried ticking and unticking TLS and SSL just to see if it helped but none of this did.

I googled as much as I could, but nothing seemed to talk about my issue, and if it did, there was no answer.


Thanks!

Chosen solution

At first,
test in this page your browser ability to establish a secure connection:
SSL Test
Also, check in about:config page that security.enable_ssl3 has a true value.
Additionally, open your Profile Folder and delete the file named cert8.db
Restart the application and cert8.db will be recreated when you do so

Note: I think if the Reset Firefox feature is of any help
Reset Firefox – easily fix most problems

Please report back!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • VLC media player Web Plugin 2.0.2
  • Windows Activation Technologies Plugin for Mozilla
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

alco 18 solutions 141 answers

Hi mariano_mariano,
sorry for posting again but could you try this Add-on HTTPS-Everywhere
and see if it works for you?

Question owner

Hello Alco! Thanks for your reply. I wanted to know, is there a way to fix this issue without using an add-on?

Regards,

alco 18 solutions 141 answers

Chosen Solution

At first,
test in this page your browser ability to establish a secure connection:
SSL Test
Also, check in about:config page that security.enable_ssl3 has a true value.
Additionally, open your Profile Folder and delete the file named cert8.db
Restart the application and cert8.db will be recreated when you do so

Note: I think if the Reset Firefox feature is of any help
Reset Firefox – easily fix most problems

Please report back!

Question owner

You're a damn genius. It worked. I will reply with the results in case someone else can benefit from this thread:

I did the SSL test and this is the result: Troubleshooting Web Login problems Your browser must pass each test shown below. 1 Are cookies enabled? [Test] (help) 2 Is JavaScript enabled? [Test] (help) 3 Does SSL encryption work? PASSED (help) 4 Do SSL addresses match non-SSL addresses? PASSED (help)

I checked the about:config and this was the data: security.enable_ssl3;true

I deleted the cert8.db file, and that seems to have fixed it! In case I need further help I will let the community know.

Thank you so much Alco, you don't know how annoying it was to have to type "https://" in every new tab after clicking on a search. I usually have more than 20 tabs open, so it's a pain in the neck!


Here's a thank you card for you! http://imageshack.us/scaled/landing/407/dscn3743n.jpg

Modified by mariano_mariano

alco 18 solutions 141 answers

Helpful Reply

Hi mariano_mariano,
I'm glad your problem is fixed!
If so, could you please mark this as solved?