X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Slow playback for animated gifs

Posted

Self explanatory: animated gifs play slow. Maybe about 75% speed. I didn't even notice till I made one myself. I can open internet explorer right now and the same gifs play fine.

Hardware acceleration on/off made no difference.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Shockwave Flash 11.4 r402
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 1.122.0
  • 1.118.0
  • 0.70.4
  • DivX VOD Helper Plug-in
  • Windows Activation Technologies Plugin for Mozilla
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Octoshape embedded video plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • npdivxplayerplugin
  • DivX Web Player version 1.5.0.52
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Firefox 18.0.2
Windows 7 Ultimate, 64bit

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Question owner

Done, didn't solve the issue.

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Question owner

Thanks for the suggestion, but it's just as slow in safe mode.

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Provide the link of the animation

Question owner

It's every gif, not just one. If you want to see the one I was testing with at the moment, it was this one:

http://images.bluegartr.com/bucket/gallery/fbc27ced6a6404571336aca3eac69869.gif

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

update your Firefox to Firefox 18.0.2 and give a try......

Question owner

I've been using 18.0.2 ><;

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

Fresh install of Firefox and Windows Safe mode didn't change the results. I'm thinking this is just a firefox flaw. Should I make a video highlighting the problem? Easy enough to do, can just record the gifs being played in both browsers simultaneously.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

What is the CPU load when you are playing such an animated GIF?

Did you try to disable hardware acceleration in Firefox?

(noticed that you already wrote that this didn't help)

Modified by cor-el

Question owner

2-3% overall, Firefox using 0%. Similiar when using IE.

i5-3570k @ 4.6ghz and a GTX680.. so I don't think specs are an issue.

Question owner

Made a video. Firefox on the left, IE on the right. Started with Firefox first, so you can watch how quickly it is overtaken by IE. (Also downloaded Chrome to test, which is identical to IE from what I can see.)

http://youtu.be/Sgn3i8tbbjQ

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Are you using firefox theme?

make use of default theme and give a try..

Helpful Reply

That was taken care of when I reset firefox, but toggling the persona has no effect.

Do you guys not see the same thing on your own computer as shown in my video? Because I'm fairly sure at this point that Firefox just plays gifs slower than other browsers.

Question owner

Have we given up?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

This may very well be caused by having a small delay between each new start of the 290 frames. I can't tell when a new sequence starts.

Helpful Reply

I'm glad you can't tell, cos that's what I tried my best to do when I made it lol. It loops at approximately the 32 second mark in the video: http://youtu.be/Sgn3i8tbbjQ

And yeah, came to the conclusion that Firefox just plays gifs slower than other browsers. Shame :(

Modified by Celeras