X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable PDF.JS and/or default to Adobe

Posted

I can't find any "addon" or "plugin" to disable. How do I disable this "pdf.js that is still under development and not stable ?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • SiteAdvisor
  • McAfee Virtual Technician plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • McAfee MSC FF plugin DLL
  • Facebook Desktop Plugin
  • Google Update
  • ActiveTouch General Plugin Container Version 105
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Updater pluginhttp://pack.google.com/
  • Office Live Update v1.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Garmin Communicator Plug-In 2.6.4.0
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Rhapsody Player Engine Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

Type about:config into the address bar, press Enter, and search for pdfjs.disabled. Double click it to set it to False.

If there is a specific issue you are having with PDF.js, would you mind letting me know so we can get it on the radar to be fixed?

Question owner

I would like the choice of having either the PDF.JS view pdf files or adobe reader, as the adobe reader has significantly better printing functions, search functions, etc.

I did turn off the pdf.js, but then rather than firefox calling adobe directly into a window like it used to, firefox immediately downloaded the file, but did not open it in adobe until I clicked the downloaded file. This is also contrary to the way firefox used to perform.

I hope this helps. I'm all for "new" features, but want to "easily" have the choice to retain previous working actions.

async5 0 solutions 1 answers

Helpful Reply

The proper way to select which application is used to view PDF files, open Preferences/Options -> Application and look for "Portable Document Format (PDF)". If you are using PDF.js as an extension, please disable or uninstall it.

mallardduck 0 solutions 2 answers

Sure - should I risk a brand-new, untested, unvetted pdf implementation that runs inside the browser itself (so if it's compromised, the attacker owns not just the container, but the entire browser session), or software that has been through the ringer over the past few years, and while it might have bugs, the obvious ones have already been patched?

Yes, that's a rhetorical question.

You guys do some good things for security like disabling flash and java, and then do some nutty things like hiding the version number, and the rapid release cycle with new features (and bugs) which doesn't give anyone time to test/vet the version. This falls into the latter category.

At the very least, when 19 installs it should prompt the user and *ASK* them what they want to do. You don't know what's best for everyone!

Modified by mallardduck

linda-t 0 solutions 3 answers

Never mind - I found it using above instructions. I just read wrong. So glad it's possible to change back to Adobe. I really didn't like the change at all. I also really would have preferred to have been offered the option to change rather than just having it forced on me! Still, I'm back to normal and able to work properly.

Thanks Linda

Modified by linda-t

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them will show you exactly how to troubleshoot or disable PDF.js

iLikedFirefox 0 solutions 2 answers

Helpful Reply

I don't get it, you guys got over 30% (in Germany over 50% !) on the marked, tendency raising, tons of cool plugins (I'm a Webdeveloper), so many happy people & recommendations, the coolest Adblock ever and so on - but you'll ruin it. You guys will just ruin it. The silent update for V19 (?) brought me, forced me, without asking me, without informing me a PDF-Plugin that has Problems rendering complex PDF-Files (like the one, that are in the web-archive of a cusomer). I have to google around to come here, jsut to get the infos. That's really uncool, so uncool that I have to register myself and write my oppinion... Where is the Problem, when U introduce something new, to let the choice by the user??? That's not just your doing, Adobe, MS etc. they all think they know what's best for the user. U DON'T! So please give at least the option to NOT WANT.

Man, i really liked Firefox but the boredom get's more and more! Updates, Crashes, now that PDF-Thing, People are running away from you and go to chrome(!) And it seems to be that you don't recon this. How do you get to your design decision? I don't get it...

Sorry4negativity, but I'm just really frustrated in the sum of the things...

Farewell.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

If you would like to disable the PDF.JS, it's fairly simple. Use the Adobe Reader plugin to view or download PDF files

mallardduck 0 solutions 2 answers

Tyler - the argument here is that Mozilla's arrogance in forcibly disabling one of the most widely used plugins, without warning or consent is, well, arrogant - especially given the new silent/hidden/stealth/surreptitious update mechanism that you guys have adopted.

The *default* should have been to leave our stuff alone. Now I understand that there are many users who aren't tech-savvy, and that there's a security argument to be made, but that implies that the mozilla solution is 1) at least as functional as Adobe's (it's not), and 2) it's at least as secure as Adobe's (unproven - and doubtful given the architecture).

At the very least the installer should PROMPT the user for instructions on what to do. Oh wait, there is no visible installer because of a previous 'we know what's best for everyone' decision on the part of the Mozilla team.

iLikedFirefox 0 solutions 2 answers

Hi Tylerdowner!

Thanx, but that's not my point. I had to google to come here, than fiddled around with the about:config, with not the desired effect, then as your quick answer came, I clicked your link, installed 50Megs of the Adobe-Stuff for Reader XI), then I had to restart my computer, then read the troubleshooting guide to switch back to the same state that I had 2 hours ago... Yep, thank you people. (BTW this and above statement is no personal offence)

I'm a PC-User, don't like Apple with their policy (and their obeiing users) but that's the thing with the easyness of iOS, i suppose. They probably have 7% of the Do this, Do that & Restart-Time-Waste... (offen per Product)

Over all, It's not getting better... So many companies miss the point, to see when something is good enough.

Thanx anyway

Modified by iLikedFirefox

Question owner

I followed the instructions to disable pdf.js and THAT worked, but the instructions to have Adobe display the document inside the FireFox window did not -- It still downloads the file and opens a new Adobe window

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96651 answers

Did you check the setting in Tools > Options > Applications for PDF or Adobe Reader files?


You can delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

linda-t 0 solutions 3 answers

PM-PC,

I found that I didn't need to do the about:config part. There's actually two sections in the options to choose which program to use. One has three items under "Adobe Acrobat" and, the key, one titled "Portable Document Format". That's the one that you have to change to "Use Adobe Acrobat in Firefox".

I hope that helps!

Question owner

GOT it -- that did the trick !! Thank you Linda-T and thanks to all the FireFox guru's for the help and timely responses.

Now we just need the McAfee issue resolved !!!  ;-) but that's coming

marimba 0 solutions 1 answers

Here are some of my specific issues with pdf.js:

1) It always loads much more slowly than Acrobat Reader.

2) About 10% - 20% of the time the document never loads. I just keep seeing the little "spinning" dashes in the middle of the page.

3) About one third of the time I get a message with the open document saying it may not have displayed correctly.

4) It always opens to a default zoom setting where the document is fuzzy. Acrobat aways opens with a crisp view.

Also, please add me to the list of people who believe we should have been asked if we wanted to switch viewers.

pekingred13 0 solutions 1 answers

I had several problems with the pdf.js format: 1.) when I downloaded a form that had been put on our website and tried to print, it would not allow me to make the form "fit" to the printer page and printed off the edges of the paper.

2.) the same form gave me a message that the file was corrupted, but when I finally figured out how to open the file in Acrobat, the form worked fine.

3.) when the same form also displayed in the pdf.js reader, some of the fonts were replaced and the form looked funky.

I am with the people that feel we should have been able to choose which format to use for displaying pdf's.