X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I open firefox and it disappears off to the side of the screen where I can't see it. How do I get it back?

Posted

I have windows 7. When I open firefox, I can see that it is open at the correct page (cause you can hover over the small firefox icon at the bottom of the screen and it shows you a small version of the internet page you are on, but when you try and maximise and get the big firefox page on your screen, it wizzes off to the side, past the edge of the screen and out of site. Not sure how to get it back. I know it's there, but can't see it on the screen! Just suddenly went like after an update on 2/13/13. Please help. Found someone who had the same problem a few years ago, but the advise isn't very clear.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2)

More Information

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Please create a screenshot of the problem you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Question owner

After numerous attempts, the screenshot will not load. I'm having to use IE which is constantly crashing on me :(

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers
  • Use Restore or Maximize in the right-click context menu of the Taskbar icon to set focus to the Firefox application if you do not see the Firefox window.
  • Open the system menu of that Firefox window via Alt+Space and see if you can move and resize that window (use the keyboard cursor keys).

If that works then first close all other open Firefox windows and then close Firefox via "File > Exit/Quit" to save that setting.

If the above didn't help then see:

See also: