X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I tried to use firefox on a site that recommends internet explorer but found that some info was missing. Please advise.

Posted

I have a Mac OS 10.5.8

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-in Version 4.0.4.0
  • Shockwave Flash 10.3 r183
  • Office Live Update v1.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Garmin Communicator Plug-in Version 3.0.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

Can you give more information?

John99
  • Top 25 Contributor
  • Moderator
622 solutions 7999 answers

You do not state what the site is.

If the site is customised to work with Internet Explorer, and possibly IE's active x then it may well not work properly with Firefox.