X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does it Firefox keep returning to 'Never Remember History' every time I switch to 'Remember History'?

Posted

I've seen numerous questions similar to this problem, but they're all about Custom Settings and none of them seem to work for me.

I want to have Firefox set to 'Remember All History' and stay that way, but when I close Firefox, the next time I open it the setting has reverted to 'Never Remember History', and all I'd done in the previous session was lost, including my cookies and log-ins.

I'm currently using the latest version of Firefox, and I'm running on Windows Vista. Everything was working fine until a few days ago after Adobe Flash crashed from being overloaded. Any help will be appreciated.

Chosen solution

hello, does anything in here help to address the problem?: How to fix preferences that won't save

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Unity Player 4.0.1f2
  • Pando Web Plugin
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • NPWLPG
  • DivX VOD Helper Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2051 solutions 8919 answers

Chosen Solution

hello, does anything in here help to address the problem?: How to fix preferences that won't save

iamjayakumars
  • Top 10 Contributor
417 solutions 4938 answers

Make sure your not running Firefox in private browsing mode

Question owner

I'm not running in Private Browsing Mode. I can switch to and from Private Browsing, however (Although there's not really much difference) and the 'Always Run in Private Browsing' checkbox in the Privacy Settings is unchecked.

Question owner

Madperson, I'll have to try out the methods on that page once I'm back on my regualr computer today.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Check the Firefox desktop shortcut to make sure that you do not have the -private switch appended to the target filed.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

So the first thing I tried was to Reset Firefox, and worked perfectly, the only inconvenience being a home-page reset, but that's fine by me. My privacy settings seem to be working now just fine. Thanks!

Thanks as well to those who gave their suggestions but I hadn't even needed to try, your help/effort is appreciated!