X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I cannot update my Firefox as the new version does not support Norton Contant Guard which I need for security

Posted

If I update to the newer Firefox I would lose my virus protection which is Norton Constant Guard. Cannot you make this compatible? Thank you, Gwynne Rattenbury

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • McAfee MSS+ NPAPI Plugin
  • Google Update
  • SiteAdvisor
  • Picasa plugin
  • GEPlugin
  • 5.1.10411.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Helpful Reply

Norton is now compatible with Firefox 18 and has been since it was released. http://community.norton.com/t5/Norton-Internet-Security-Norton/Firefox-18-Support-for-Norton-Toolbar/td-p/886718

Please note that all firefox interacts with is norton toolbar, which does nothing to improve your security. Your anti-virus will still protect you no matter what browser you use. Update to firefox 18.0.2 immediately, then run norton live update.