Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

XP SP2 FF18 doesn't start, not even in safe mode

  • 12 replies
  • 2 have this problem
  • 239 views
  • Last reply by John99

more options

Crash-ID: bp-4d3255a5-1f8f-468e-b450-ef8a32130210

Chosen solution

have you tried installing the updated version yet, that is available at http://eid.belgium.be/en/using_your_eid/installing_the_eid_software/ ?

Read this answer in context 👍 2

All Replies (12)

more options

hello, the crash is caused by the Belgium eID MiddleWare by Belgian Government running on your system. do you need that software? if not please uninstall it or else contact its support to see if an update is available or if they can address the issue otherwise: http://eid.belgium.be/en/using_your_eid/need_help/

more options

That looks like a problem with your Belgium eID software (beid35cardlayer.dll), so you will have to disable their Firefox extension or possibly disable or uninstall related software.

more options

The crash is caused by your eID software as mentioned above.

Possibly updating that will help. I believe the site may be

You appear to be using version 3.5.1.5075 is that the latest version


For forum cross referencing purposes

  • Crash ID report bp-4d3255a5-1f8f-468e-b450-ef8a32130210
    • Crash Signature: beid35cardlayer.dll@0xa561
    • Related Bugs 831286 NEW --- Startup Crash @ beid35cardlayer
    • version beid35cardlayer.dll 3.5.1.5075
more options

beid35cardlayer.dll is a beidcardlayer of the Belgian Government and part of the beid35cardlayer.dll plug-in.

There is no possiblility to start in safe-mode; because the first window of Firefox does not appear.

more options

Hold down the shift key while starting Firefox, to start safe mode.

more options

I already tried that, Ideato. Nothing happens, no window, no nothing.

more options

Update the Belgium eid software, they have fixed the crash

more options

No doubt you are still wondering how to do that if you can not start Firefox.

Easiest optons first (if they work for you)

  1. Ask your IT department
  2. As already suggested try pressing the shift key as you try to start Firefox
    Diagnose Firefox issues using Troubleshoot Mode
  3. Use a command-line or a modified shortcut. Basically you leave a space then add -safe-mode that will be outside of any inverted commas that are needed for the path.
    http://kb.mozillazine.org/Safe_mode#Windows
  4. Carefully reinstall Firefox

As soon as you have a working Firefox install the latest version of the Belgian software.

more options

Starting in safe mode using a command-line doesn't work.

Reinstalling FF as suggested in 4, doesn't bring a solution. Instead of starting FF, I still get a crashreport.

more options

Chosen Solution

have you tried installing the updated version yet, that is available at http://eid.belgium.be/en/using_your_eid/installing_the_eid_software/ ?

more options

After installing the updated version of the E-id software and disabling the add-on no problem starting up FF18.0.2

Thanks for your help ! Relieved Firefox finally works.

more options

Edit
Glad to see it is now fixed.

I took a lunch break in the middle of writing this, and I see you have now fixed it. I was unsure if you may have already updated the software, it has been suggested a few times. It would probably be a good idea to learn how to use Firefox's Safe Mode, it is very useful in troubleshooting and fixing problems.


Sorry,
my last answer point 4 was not the best idea because it leaves you with the extension causing a startup crash.

I guess I was hoping you would find one of the other methods would work. Then if necessary the reset option could have been employed, but that needs Firefox to at least give you that option. I am still not sure why you seem unable to start in Firefox's Safe Mode

By far the easiest thing is normally to try to follow the safe-mode instructions. i.e. hold the shift key down whilst using the mouse to click/doubleclick the Firefox icon.

If you are still unable to start in safemode, then to start without the extension do one of these.

  1. Rename the extensions folder. That should effectively remove all or most of your extensions. That involves you finding the profile (much easier with Firefox running) then looking inside it for a folder named extensions. Rename it to oldextensions See
  2. Create a new profile. The easiest method is using the built in profile manager. (That part starts up before Firefox looks at the problem profile and so should not crash) The instructions are in these articles
    Profile Manager - Create, remove or switch Firefox profiles
    http://kb.mozillazine.org/Profile_Manager#Creating_a_new_profile
    1. You will be asked for a name for the profile, I suggest you use New01
      Do not try renaming or deleting profiles, it is far too easy to destroy information,even none Firefox files. (Just delete unused shortcuts)
    2. After you have done that you will need to migrate as much as is safe of the old profile. That gives you the bookmarks etc. back The instructions are here:
      http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Modified by John99