X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Privacy settings stuck on "Never remember history".

Posted

I want "Use custom settings for history" but Firefox keeps reverting to "Never remember history" no matter what I do. Happens with FF 18.0.2 on both Win7 and Win8.

Chosen solution

Installed 19B on Win8 and initially got same results but then I fiddled a bit with the custom settings and it all seemed to come right.

Thanks Cor-el

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.6 r602
  • np-mswmp
  • Conduit Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • VLC media player Web Plugin 2.0.2
  • Picasa plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.
Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.
If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".
"Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a check mark.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

If you do not keep changes after a restart then see:

Chosen Solution

Installed 19B on Win8 and initially got same results but then I fiddled a bit with the custom settings and it all seemed to come right.

Thanks Cor-el

warmspirited 0 solutions 4 answers

I racked my brain on this, having the same problem., going through page after page of reading and trying solutions. I rebooted, and clean-booted, and even re-installed Firefox, and several times resetting my setting....it took hours...

Yet the answer is so amazingly easy!

If you select "Use custom settings for history", all the check-boxes shown are defaults. YOU MUST ACTUALLY CHANGE ONE OF THESE FOR IT TO BE A CUSTOM SETTING. Otherwise, the next time you open the privacy tab, the pulldown will revert as if you never selected it.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

The "Use custom settings for history" choice allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.
Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.
If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".
"Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a check mark.

"Use custom settings for history" stays selected if at least one of the History or Cookie settings is not the default to make you aware that changes from the default setting have been made.

warmspirited 0 solutions 4 answers

The "Use custom settings for history" choice will be retained ONLY if you change one of those settings. Otherwise, the next time you open the privacy tab, the "Use custom settings for history" will not be shown.

I needed to change my cookies settings, but every time I opened the privacy tab, it reverted back, unless I actually made a specific change.

I actually WANTED the default settings, but the browser would not change to them until I chose one of those check-boxes.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Firefox won't keep the "Use custom settings for history" selection if all history settings are the default like I wrote above.
This doesn't mean that you can't make other changes or inspect the cookie exception, but this will require to (temporarily) select the "Use custom settings for history" every time you need to go there.

warmspirited 0 solutions 4 answers

I guess you do not understand the question, but why the heck are you arguing with me?

I found an answer and shared it. Now leave it alone.

Frankly, I did not find your wording very clear, else I would not have spent hours trying to follow it. So, I came back and posted my own thoughts lucidly, and you jiust had to follow up with another copy of your confusion.

Thanks.

Modified by warmspirited

warmspirited 0 solutions 4 answers

It was nice to read that mess a second time, as if it did any good the first time.

Modified by warmspirited