X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why is there a delay when I open my tabs one by one it’s so annoying?

Posted

When I start my computer everyday and try to open Firefox it takes me 30 sec to open. And the most annoying thing when I am in a rush trying to open 2 tabs at the same time it takes so long. It does this every time I upgrade please help,.

Modified by rank_high

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.13.2.11592
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Shockwave Flash 11.5 r502
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • iTunes Detector Plug-in
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Google Update
  • 5.1.10411.0
  • Picasa plugin
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Question owner

Also it freezes as you can see and not responding and 10 sec later after it works.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello, can you try to replicate this behaviour when you launch firefox in safe mode once?

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

smo 45 solutions 498 answers

Have you checked your settings for startup? in your Options > Tabs, is the checkbox Dont' load tabs until selected checked? If not, Firefox will open all your tabs, when starting - and that can be quite a lot to chew through.

See more here: Startup, home page and download settings

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox profile folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.