X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox version 18.0.1 can't open .doc files with software restriction policy turned on

Posted

Firefox (and Thunderbird) can't open .doc .xls files directly (open with) Word, Excel, Powerpoint, 7-zip

> Access to C:\Program Files\Microsoft Office\Office14\WINWORD.EXE has been restricted by your Administrator by the default software restriction policy level.

There is no different when files are opening from website or from disk. Important only select option "open with". However Firefox (and Thunderbird) are normally opening .pdf files with Foxitreader or .doc files with Wordpad.

In the same time Internet Explorer, Windows explorer, start file1.doc (in command line) opens file NORMALLY. Word, Excel, Powerpoint and 7-zip starts with no problem.

Seems like the problem appears only when Mozilla products try to start MS Office 2010 products. And now I found problem with opening .rar archive when Mozilla is trying to start 7-zip.

ERRORS: > Access to C:\Program Files\Microsoft Office\Office14\POWERPNT.EXE has been restricted by your Administrator by the default software restriction policy level.

> Access to C:\Program Files\Microsoft Office\Office14\EXCEL.EXE has been restricted by your Administrator by the default software restriction policy level.

> Access to C:\Program Files\7-Zip\7zFM.exe has been restricted by your Administrator by the default software restriction policy level.

POSSIBLY SOLUTION: I think the problem is on way which Mozilla products execute files.

SYSTEM: Windows Server 2008 R2 Enterprise 64 bit SP1

Thanks a lot!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Software602 Form Filler Plugin for Mozilla
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello younghacker, one thing you could try is to enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.download.manager.scanWhenDone. double-click it and change its value to false.

http://kb.mozillazine.org/Browser.download.manager.scanWhenDone

Question owner

Thanks you for quick answer.

But I have tryed set this options to false. And restart FF. Nothing, error still present.

browser.download.manager.scanWhenDone;false services.sync.prefs.sync.browser.download.manager.scanWhenDone;false

Now i have write small test application thats will start program

#include <windows.h>
#include <stdio.h>
void main(int argc, char *argv[])
{
	static char CommandLine[4096];
	if(argc < 2)
	{
		printf("\nSoftware Restriction Policy ByPass for FireFox Thunderbird.\n"
						"Set this Application Name as Mail Attachment Processing Handler.\n");
		return;
	}
	sprintf(CommandLine, "Start %s", argv[1]);
	system(CommandLine);
}

Application is setup in FF as application for .doc files. And start. But error still present.

But if I set IE as application for .doc files IE will start and will open .doc with Word!

I have found that MS Office and 7-zip, that not works, - are 64 bits applications. Foxitreader is 32 bit application that is work normally. Firefox also is 32 bit.

Modified by cor-el