X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Mozilla should be able to provide adequate alternatives for extensions become unsupported through extreme high release frequencies

Posted

Hello Firefox Fans,

I have Firefox 3.6.28 still running daily on my PC under WinXP. Do not ask how old it is.

The one and only reason I haven't updated yet is that my favourite extensions does not work on newer versions. It's a very time-consuming process to find, install, and configure them, and since Firefox's main release frequency is constantly increasing, I can never tell how often will I have to do the same task of several hours in the future, if I want my Fox to be up-to-date.

This is why I do not update.

A few weeks before I ghosted my OS and tried to update Firefox to the latest of that time, but the results were so poor that I restored the full backup quickly.

One reason why I do not put my extension list here in the first post initially is that I think it's not the proper way to get the missing info I need if I have to compose a forum post, interact with others and wait for answers to get my Fox being updated properly. The other reason is that I do not post because I want my problem being solved by others, but rather wondering the community's opinion about my question.

Updating Firefox properly is a very time-consuming and annoying process.

Opinions welcome :-)


Peter Borosnyay (36) computer programmer

Chosen solution

So, just to make sure you have the most satisfactory experience with Firefox, these are the steps you should follow:

  1. Update to Firefox 18.0.2 Update Firefox to the latest version
  2. Uninstall Tabkit, install Tabkit 2 and update all your other add-ons
  3. Update your plugins (yours are horribly out of date which will cause major problems) http://ninite.com/flash-java/ninite.exe
  4. Just to make sure everything else is fine, run all Windows updates and update your graphics Driver to give Firefox the best performance it can get. Upgrade your graphics drivers to use hardware acceleration and WebGL
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

First, which addons don't work in Firefox 18.0.2?

Also, update frequency is not at all increasing, we release every 6 weeks, it's been that was since Firefox 6 and there are no plans to increase at all. Also, if you have an extension working in a modern version of Firefox (like 10 and above) any updates to Firefox from then on won't disable that add-on.

Basically the situation has changed since you last tried it. The only "work" you will have to do is the update from Firefox 3.6 to 18.0.2, and updating your extensions (most of your extensions will probably work, they just need to be updated after Firefox is updated). After that, updates won't touch any of your extensions. The 15 minutes it will take you to update everything is definitely worth the benefits of having a secure browser (Firefox 3.6 has about 100 known security holes) and better performance. Not to mention more modern web technology and standards compliance.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, addon compatibility after updates in current firefox version shouldn't be an issue any longer for extensions that were made compatible to work with firefox 4+: https://wiki.mozilla.org/Features/Add-ons/Add-ons_Default_to_Compatible

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

If you would post your list of installed extensions, and mention which extensions haven't been updated beyond Firefox 3.6.28, I am sure there are users here who could recommend a suitable replacement extension.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

you should probably also keep your plugins updated - some of them are out-dated & have security vulnerabilities that are actively exploited on the web.

Question owner

Thank you :-)

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Helpful Reply

Ok, so this is a list of your addons that will work:

Ad-Block Plus: This will work. You'll have to update to version 2.2.2 after you install Firefox 18, but it will work fine.

Autoformer: This will work fine

iMacros for Firefox: This will also work after an update to 7.6.0.2

Personas: You don't really need this anymore, Firefox has the ability to load Personas built in now. you can remove that add-ons. If you want the addon you can continue to use it.

Tabkit: This was abandoned by it's developer, but you can uninstall it and use https://addons.mozilla.org/en-US/firefox/addon/tabkit-2nd-edition, which is the same thing, just compatible with modern versions of Firefox

Tineye: This will also work after an update to 1.1

All the other extensions you have are disabled.

So, good news, it looks you only need to uninstall tabkit and install tabkit 2, and then update the other add-ons after you install Firefox 18.0.2.

And of course update your plugins ;)

Question owner

(Un?)fortunately I use Firefox tabs instead of post-it notes for my daily todo reminders ... if I find a page interesting and don't have time momently to study it, I leave the page open on a tab ... my favourites are also permanently open ... Fox 3.6.28 uses 1 GB of RAM in average. And, it's really really slow to start but even right-click menu takes a nearly unacceptable 1000 msecs to appear sometimes ... it looks like the more time Fox running the slower and slower everything gets ... especially when using facebook. Really would be glad to solve this ONCE ... NOT monthly ...

Thank you :-)))

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Helpful Reply

Well that is exactly the reason you should update to a more modern version of Firefox. Firefox 3.6 is notorious for it's memory usage, and, especially in recent versions, Firefox has been FAR better at managing memory and maintaining speed over long browsing sessions. As I've said before, updating to Firefox 18.0.2 and updating your addons is not just going to make you more secure, it's going to make your whole browsing experience better.

Question owner

Thank you, this is the info I exactly needed.

Sorry for being pessimistic out of misinformation at first sight.

-)))
Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Chosen Solution

So, just to make sure you have the most satisfactory experience with Firefox, these are the steps you should follow:

  1. Update to Firefox 18.0.2 Update Firefox to the latest version
  2. Uninstall Tabkit, install Tabkit 2 and update all your other add-ons
  3. Update your plugins (yours are horribly out of date which will cause major problems) http://ninite.com/flash-java/ninite.exe
  4. Just to make sure everything else is fine, run all Windows updates and update your graphics Driver to give Firefox the best performance it can get. Upgrade your graphics drivers to use hardware acceleration and WebGL

Question owner

Tylerdowner, Really THANK YOU for your enthusiasm. I hope I will have the same too soon.

-))

Question owner

Hello Tylerdowner,

I tried it today, looks good for 1st sight. Especially the "Don't load tabs until selected" option is very useful for me. But, if I click all tabs to load everything, RAM usage goes a bit above than it was with 3.6.28, up to 700MB including plugin_container.exe. Then I restarted Fox and recovered more than half a GB of RAM this way. See the 1st attachment.

Some questions :

How can I uninstall plugins ? There's no uninstall button like in the Extensions manager. Btw. what's the difference between plugins and extensions ?

Previously I had the cache folder redirected to a ramdrive for saving my SSD's write cycles. Now I don't see the corresponding folder on the ramdrive, and I remember I've done this by setting browser.cache.disk.parent_directory to T:\FireFox\ manually. The setting is still there, but Fox doesn't create the folder for itself automatically like he did before. Do you know why ?

Thanks a lot ;-)))

Peter

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Plugins can't be uninstalled from Inside Firefox, but disabling them is the same thing essentially. Uninstall them from the Windows Control Panel.

As for memory, please note that plugin-container holds plugins such as Flash and java, and thus memory usage of plugin-container isn't managed by Firefox.

You can try to help reduce memory usage by typing about:memory into the url bar, press enter, and click the "minimize memory usage" button.

James
  • Top 25 Contributor
  • Moderator
437 solutions 3156 answers

Plugins cannot be uninstalled this way simply because they are not installed in Firefox like Extensions and Themes are. You can tell Firefox to not make use of the Plugin(s) it find by disabling it.

Modified by James