X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I use Firefox 16.0.2 on Leopard. Problem: after using succesfully an url on a site, original site(with url) has disappeared.

Posted

I use Firefox 16.0.2 on Apple Leopard. Problem: when I use an url on a site, I am correctly transfered to the site of the url. But I can't go back again to the original site, on which the url was mentioned. the site has disappeared. Thanks in advance for your help!

Additional System Details

Installed Plug-ins

  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.1.3
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Office Live Update v1.0
  • RealPlayer Plugin
  • Shockwave Flash 10.3 r183
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 5.1.10411.0
  • Met de QuickTime-plugin kunt u een grote verscheidenheid aan multimediamateriaal op webpagina's bekijken. Raadpleeg voor meer informatie de website van QuickTime.
  • Picasa plugin.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

finitarry 157 solutions 2177 answers

Are you allowing any history to be saved? In Preferences > Privacy, is the checkbox for "Remember my browsing and download history" checked? I do not think the back button will work if that is not checked.

Question owner

@finitarry, Thank you very much for taking the effort fot replying. I did all the possible things I could do, including your advise. But I discovered that there was something wrong in my ~/Library/Mozilla/Firefox/Profiles/ ~/Library/Application Support/Firefox/Profiles/

Even renewing had no sense. So I reinstalled the Firefox completely. In that respect the problem is "solved"!

Question owner

I was too quick in using "solved". In the newly instaled Firefox I keep having this problem, in spite of your advise....

finitarry 157 solutions 2177 answers

There is one more thing you could try. No guarantee it will work, though. If you type about:config into the address bar, then agree to the promise that you will be careful, you can change this setting:

browser.cache.check_doc_frequency - set to 2 (meaning never)

If the page is in the cache, there should be no problem in retrieving it, provided that the page itself is not being prevented from caching.

Question owner

finitry! Thank you again. I'm not a great hero....If this action fails, becomes a disaster, the end of everything (I'm a pesimist), can I than reset this action? Further: do I have first to open a certai site? F.i. a site as I have dscribed in my topic? So, when I click on an url on a certain site, after arriving there, not being able to return to the original site? Thank you in advance! Gr.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

Helpful Reply

You can also open the links in a new tab with a middle click on the link.
That way you do not need to use the Back button, but can simply close a tab or otherwise return to the previous tab.
Also make sure that you have the cache enabled and that the cache is working.
Check the current cache usage on the about:cache page.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Both @finitarry and @cor-el, I thank you very very much for your exceptional quick, relevant an helpful advises. For the time being I'm very glad with the advise " open the links in a new tab with a middle click on the link". That works perfect.The other advises I will test later as well, and I am very confident that they will work as well. As far as I see it, I regard my problem as solved and as "very helpful. Thank you both again very very much. I wish you all the best!

Question owner

I'm sorry to come back (I don't blame you). I have to tell you that all the actions as described above did not work, or I could not find the cause. Only one advise, "open the links in a new tab with a middle click on the link", is very useful. I'm considering now to reinstall the Firefox. For that action I saved already all my bookmarks.

Question owner

Strange....I found the solution finally elsewhere: Preferences/Tabs deselect "New windows in new tab" (free tranlation)