X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Internet doesn't work after VPN reconnects unless firefox is restarted

Posted

When I connect to Office VPN through Juniper Cisco Client, there is a script that automatically configures the proxy in "Automatic proxy configuration URL" in firefox. Everything works fine. I am able to browse the internet and also access my office tools. However, in between, if the VPN disconnects and reconnects on it own (due to any reason other than manual disconnection) , I am then not able to open any website. Firefox behaves as if there is no internet connection. I tried changing the proxy settings to "No proxy" but no use. I then again set the proxy settings to be that of VPN but the result is the same. The only solution is that I close firefox and open it again, I am then able to browse without making any changes in the proxy settings. This is frustrating because I have to close all the websites and firefox and open it again to access the internet. I am running Windows 7 Enterprise Edition and have Firefox 18.0.1 installed.

The issue started after I upgraded to Firefox 18.0.1 . On previous versions, there was no such issue.

I have tried similar thing on IE but IE works fine. Even if the VPN disconnects and reconnects several times, IE allows me to browse the websites and continue my work from where I left.

May be some kind of bug on this latest release.

Regards, Alok Verma

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Does it help if you toggle the online status off and on again?

  • Firefox > Web Developer > Work Offline

Helpful Reply

Hi Cor-el,

Haven't tried that yet. Will try the next time when VPN automatically disconnects and reconnects on its own.

There is no "Work Offline" option in Firefox > Tools > Web Developer. I guess you meant to say Firefox > File > Work Offline (check and un-check)

Question owner

Same thing happened again. VPN got disconnected and reconnected on its own. But couldn't browse websites using Firefox . Other applications like gtalk, skype etc started working after VPN reconnection but not firefox. I then checked "Work Offline" under File menu , tried to browse the website after which got the message Firefox is under offline mode. Then again unchecked "Work Offline" and tried to browse, (refreshed existing website as well as opened new website) , but it didn't worked.

mosses 0 solutions 1 answers

I have this problem too, I just tried the Work Offline option however it didn't help.

Any other idea. I have a lot of tabs opened and the unique solution for now is restart the browser.

Firefox win7 version 21.0