Question

How do I get Firefox to allow secure connections with sites I trust?

I just updated to the latest version of Firefox (18.0.1) and I find that I can no longer navigate to fully half of the sites I used to, such as Gmail and Facebook. Most of the sites I go to now don't even look right, they just display text, no UI. Even as I type this up, there's only text. I tried to use Firefox's own tool to find which plugins I had installed, and it gave me the same "This connection is untrusted" message. Most of the sites I got to allow me to make an exception, but Gmail doesn't, nor does the Firefox plugin page. I've used Firefox for years but this is the first time I've ever had an issue like this.

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • post
  • helpful
  • post
  • post
  • owner
  • solution
  • owner
  • helpful