X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Issues in Firefox - Missing Reset Firefox to it's Default State

Posted

Got a few quirks with Firefox (font issues) after installing some add ons. Restarting disabling the add ons does not fix the issue.

Wanted to reset Firefox preferences. Went to "Help>Troubleshooting Information". It brought up a screen with all kinds of information on it, but there is no "reset" button in the upper right (or anywhere that I can see) on the page.

I running under Linux desktop (Fedora 17). The version of Firefox is 18.0.

Additional System Details

Installed Plug-ins

  • Mime Type x-skype for Skype Buttons
  • Shockwave Flash 11.2 r202
  • Gecko Media Player 1.0.7Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The Totem 3.4.3 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • Xine Plugin version 1.0.2, (c) The Xine Project.Windows Media Player / RealPlayer / QuickTime compatible.
  • MozPlugger version 1.14.3, maintained by Louis Bavoil and Peter Leese, a fork of plugger written by Fredrik Hübinette.For documentation on how to configure mozplugger, check the man page. (type man mozplugger) Configuration file:/etc/mozpluggerrc Helper binary:mozplugger-helper Controller binary:mozplugger-controller Link launcher binary:mozplugger-linker

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
418 solutions 4938 answers

Update to Firefox 18.0.1 and give a try...

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You only have the Reset button if you have started Firefox with the profile that is marked as Default=1 in the profiles.ini file.

You can delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Can you attach a screenshot to show the font problems?

Use a compressed image type like PNG or JPG to save the screenshot.

Question owner

I saw that in my earlier searches (before I posted).

I'm not working with multiple profiles.

from my home directory ~/.mozilla/firefox/profiles.ini


[General] StartWithLastProfile=1

[Profile0] Name=default IsRelative=1 Path=jhn3pg5a.default Default=1


Only 1 profile defined and the default flag is set.

Should I be looking somewhere else as to where it's getting it's information from?

Question owner

Accidentally hit that the 18.1 upgrade solved the problem. Not sure if it will or need. I'm updating from Fedora's yum repositories and it hasn't hit there yet.

Question owner

Image attached. I was fooling with the add-on Theme Font and Size Changer which really helps with high resolution screens (1920x1080). What I noted though is some (and only some) of the buttons and text boxes took on a larger size as well. Resetting them in the tool and even disabling all add-ons does not fix the problem.