X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to permanently disable click-to-run "feature" on all plug-ins

Posted

How can I permanently disable the click-to-run "feature" for all plug-ins *including* ones that are unsafe, exploitable, etc.?

I know that this is "unsafe", "inadvisable", a "security risk", etc. however this question has been asked many times and I have not yet found an answer. My reason for wanting to do so is not important and there is no point in questioning it; this is a simple question with what should be a simple answer, and does not require the bickering and arguing that always ensues when someone asks this extraordinarily basic question.

I want to permanently disable any and all forms of click-to-run for any and all plugins, so that all plugins run without having to be clicked first and show absolutely no warnings whatsoever of any kind. If I don't want to run a plug-in I will disable it.

How can I do this very simply thing?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • SumatraPDF Browser Plugin
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • IE Tab plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

erze2010 0 solutions 1 answers

There is a way to stop the plug-in using Mozilla, but it may not be permanent. The instructions online for Windows aren't exact. I managed to click the false to stop the plug-in. It was great being able to be on the Internet without my system locking up because the plug-in uses up a huge chunk of memory.

Then...it shows back up! I may stop using Mozilla because of the slow downs. Chrome has to many ads. Inter Explorer isn't suppose to be all that safe.

So if Mozilla doesn't get that stupid memory hog plug-in fixed, I'll go to Opera.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Some outdated plugins (e.g. Flash plugins) are blocked via click-to-play and can be enabled when required.
It is best to update such a plugin to the latest version to be protected against security vulnerabilities.

You would have to disable blocklisting to circumvent this and that is not recommended.

FredMcD
  • Top 25 Contributor
114 solutions 1458 answers

If you think a add-on is not working properly for you, or you want to stop the add-on from doing its job, Go Firefox Options > Add-ons. Then go thru each add-on and you can choose to Disable <stop working> or Remove <uninstall from Firefox> for each one.