X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Google Maps slow to load

Posted

Hi,

I appear to be having issues with Google Maps and Firefox.

Google Maps loads fine but then once trying to utilise the maps every operation is extremely slow and clunky, sometimes taking up to 30 seconds to complete the command.

I have tried Google Maps on Safri and don't have the same issue so can only assume it is a compatibility issue and nothing to do with internet speeds. Furthermore, I don't appear to be having any similar issues with other websites........for instance, I can watch 1080p You Tube videos without much need for buffering.

Any suggestions in laymen terms please as I'm no where near technical enough for the usual jargon ;)

Additional System Details

Installed Plug-ins

  • Version 3.13.1.11376
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • FireFox Coupon Printer
  • 20-20 Technologies - 20-20 3D Viewer for IKEA v5.0.7.0
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Thank you cor-el.

Went through the long and arduous task of checking the extensions and found the culprit. In my case it happened to be Ghostery!