X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to remove http://searchiu.com/?affil=141

Posted

Greetings! I've downloaded a program and here was some virus, now i alway have this page http://searchiu.com/?affil=141 as a start page and i'm afraid of my security. Can you help to remove this virus and get back my start page? Thanks you!

Chosen solution

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes then see:


Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Read this answer in context 20

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • Next Generation Java Plug-in 1.6.0_39 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Pando Web Plugin
  • 4game browser plugin
  • McAfee MSS+ NPAPI Plugin
  • Facebook Desktop Plugin
  • iTunes Detector Plug-in
  • npdnu
  • npdnupdater2
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Roshan 0 solutions 7 answers

Please follow the following steps to change your start up page on Firefox.

  1. Open Firefox
  2. Click on Tools tab on the menu bar
  3. Click on Options
  4. Click on General tab located on the top
  5. In the Startup panel click on Restore to Default button
  6. Click OK
  7. Restart Firefox and see if you get Firefox start up page now
cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Chosen Solution

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes then see:


Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

bethg 0 solutions 1 answers

Thank you for this advice. That searchui redirect was making me crazy.

payam_shp 0 solutions 1 answers

please follow this webpage http://www.anvisoft.com/resources/how-to-uninstall-searchnu-com410-uninstall-guide/ How to Uninstall Searchnu.com/410 (Uninstall Guide). After following the steps ,download the mentioned software which is free at first. It is amazing, after too many hours searching finally I could recover my browser. If you download new search toolbar through this steps just go to control panel and delete new search tool bar.Many thanks to Anvisoft's admin.

Modified by payam_shp

Michto 1 solutions 6 answers

Use this guide to remove typical redirects http://remove-free.com/removal-google-redirect-virus-overview-causes-and-solutions I had the same problem with Searchnu parasite. Clean your .hosts

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

For anyone still having an issue with searchiu who remembers how they received this, please Private Message me. We are trying to block this add-on for all users in the future and we need to have a copy of it to do research on.

Evets616 0 solutions 1 answers

I tried everything written here and then some.

I installed several additional anti-virus programs. Restarted in Safe Mode, ran them all, restarted again in Safe Mode, ran em again. When I was back in the regular Windows7, Firefox still opened to the searchiu page.

I uninstalled Firefox, but kept my personal settings. That didn't work, it was still there after reinstall. So I backed up my bookmarks, took screenshots of my list of addons and nuked Firefox, complete uninstall of the program and all my personal information and setting.

Only after this final step, did I stop seeing the searchiu page.

ArieCuk 0 solutions 3 answers

I just not tried to uninstall FireFox and start from scratch.

AV runned and did not found anything. THREE malware/spyware were runned and nothing. Chrome and IE are OK!!!

Can someone help me?

ArieCuk 0 solutions 3 answers

Helpful Reply

Hi all, Theoretically I made it. I found the string "http://searchou.com/?id=..." in users.js and prefs.js files.

At users.js file i fount it in:

  • extensions.privitize.tlbrSrchUrl
  • extensions.privitize.kw_url
  • extensions.privitize.newTabUrl
  • extensions.privitize.hmpgUrl (not sure)

At prefs.js file i fount it in:

  • extensions.privitize.lastB

HTH

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Pref like extensions.privitize are added by an extension with a name like privitize and you need to remove or at least disable this extension.

ArieCuk 0 solutions 3 answers

cor-el,

cleaning this preferences was the way I resolved my problem. Unfortunately this solution is to late to Evets616 , who uninstalled firefox and reinstalled it. Regards Arie

Polarbear332 0 solutions 2 answers

Helpful Reply

Hi all, Like the people above i tried everything mentioned and that didn't work for me either. I have found the following;

  • 1 go in FF to the menubar and click help
  • 2 choose the 'troubleshooting information' option
  • 3 search in the presented page for a click-able file named "user.js"
  • 4 click on this file and in this file you will see all kinds of instructions for the searchiu "virus"
  • 5 open the path to this file and delete it
  • 6 restart firefox and my problems were gone

I hope this will help you terminating the searchiu pest

Regards

Modified by Polarbear332

Mr-Love 0 solutions 9 answers

I also had that "user.js" which contained nothing but 7 lines of "u-Search" crap (see attachment), but deleting it didn't change a thing.

However - I then somehow opened "prefs.js" in the same folder (with Firefox closed), searched for u-Search, found plenty of entries (similar to the ones in user.js) which I all deleted and voilà - Firefox was back to the default new tab and homepage behaviour!

(This after I'd tried I don't know how many different suggestions. I'd really like to know from where I got that thing in the first place...)

Modified by Mr-Love

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You will still have to remove those lines from prefs.js or reset them on the about:config page.
Removing them form the user.js only prevents that they are recreated on each Firefox start.

FieldDandelion 0 solutions 2 answers

I did iT!!! Thanks a lot. With Firefox OFF. I follow the same path you did. But in the same folder: file:///C:/Users/John/AppData/Roaming/Mozilla/Firefox/Profiles/wuuo11y5.default/ i SCANNED 3 FILES: prefs prefs.js (file BAK) prefs.js.new Open 'em with notepad program then look for: "u-Search" AND found many (5-7) beasts !! ERASED them ! Then open a clean FF !! CHEERS !

Armando 0 solutions 1 answers

i'm almost sure, any of these have the issue with it

groove shredder pluggin groove shredder patch groovedown

when i installed these my firefox was messed.

Polarbear332 0 solutions 2 answers

You can be sure, i got this 'infection' from the groovedown installer when i forgot to optout for all kinds of 'extras'

FieldDandelion 0 solutions 2 answers

I confirm it came from groovedown-crap, but I did't forget to opt out the "extras" beasts, nevertheless they were dropped on my computer. GRRRR.... It's gone now.