X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 18.0.1 often freezes, at random times, since about 31 Jan 2013

Posted

2 Feb 2013 Concerns: Firefox 18.0.1 often freezes, at random times, since about 31 Jan 2013 I am using Mozilla Firefox 18.0.1, Windows Vista, PC, Desktop. My Mozilla Firefox freezes since about 31 Jan 2013 at random times quite often, when I do see TV or videos, also with YouTube videos. It freezes especially when I do start TV or a Video, sometimes also it freezes when the video is running for some time. I do use Firefox mostly only for TV and videos, so else I do not see. Some days earlier (26 January 2013), I had installed the upgrade of the new Norton Internet Security 2013. The two Norton add-ons on for Firefox, I have both deactivated. I can get out of the freezing, when I do click to end the Internet connection. After I have waited for about 5 seconds, the Mozilla Firefox browser can be moved again with the cursor. After I click to close the Firefox, and wait for about 5 seconds, the freezing also does end. I did do two Windows restores, one to 1 week ago and the next to 2 weeks ago. After the restore, when I started Mozilla Firefox, it was at first Firefox 17. But to my very bad luck, Firefox started immediately to update to Firefox 18.0.1 I had seen this updating on Help – About Firefox. There were good times, when people could choose themselves which version of Firefox they wanted. After the restore, I had also downloaded the latest Adobe Flashplayer version (about version 11.5), but the freezes have remained the same. Is there a possility to prevent the automatic update of Firefox? So that I could choose which version of Firefox, I do want. When there is a serious bug in Firefox, I could nevertheless use Firefox instead of changing to the Internet Explorer. I know I myself am responsible to prevent hackers from entering my computer. I have read that 80% of users in Germany do not have any Internet Security against hackers at all. My Internet Explorer until now does not freeze.

Chosen solution

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.11.7.10909
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • npCNTVLive2 Plugin For FireFox&Chrome
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • QQ2011
  • 5.1.10411.0
  • VLC media player Web Plugin 2.0.0
  • NPTXSSO Dynamic Link Library
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • CCTVplayer plugin for Firefox
  • Winamp Application Detector
  • nprt
  • Yahoo Application State Plugin version 1.0.0.7
  • Office Live Update v1.5
  • 2,5,3,1
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cybervigilante 0 solutions 12 answers

Yeah, it all hangs. Ctrl-Alt-Del doesn't even fix it until the stupid background program is done loading. Unfortunately, most sites now load three to a dozen of the damn things. And if the server for the background site is clogged, FF just spins your disk. It's a real PIA. I'm slowly choking it out by altering my hosts file, but if you don't know what to do with that, it's best to leave it alone ;')

jscher2000
  • Top 10 Contributor
2365 solutions 20934 answers

Hi NotionCommotion, I'm not familiar with a 30 second freeze and then a "bing" sound. Does this occur at start-up, or at any other time consistently?

What is your OS? If you run Windows Vista or newer, do you notice any correlation with use of Flash?

NotionCommotion 0 solutions 6 answers

Hi jscher2000,

Seems like no rime or reason. Just Occur during accessing various websites, and seems to want to download something.

OS: Windows7 Flash: No Plugins:Firebug and a few more. Occur during startup: No

Modified by NotionCommotion

cybervigilante 0 solutions 12 answers

Specifically, when FF freezes, look at the lower left of the browser for the background loader that is freezing it - usually something like cdn.bunchofcrap.com to load external resources, or an ad or analytics site. Then go to the hosts file in Windows and block it totally so it doesn't even try to load. The more crapsites you block the fewer freezes. Check Google for how to edit the hosts file in win 7.

The ads and analytics - phooey on them. As for the external resources, you might miss some fancy fonts, but that's better than freezes. I've never seen a problem with jquery, which is a very common background loader, but it appears to have good support and isn't large so it doesn't stall FF.

NotionCommotion 0 solutions 6 answers

Hy Cybergigilante,

You describe my symptoms exactly.

jQuery is just JavaScript, and as you indicate is very popular. I can see bad jQuery/JavaScript crashing FF, but wouldn't expect it to crash the entire OS.

Do I understand your recommendation is that in the ../etc/hosts file, we should assign a fictional IP to resolve to to any sites such as cdn.bunchofcrap.com which mess with FF? I can't believe Mozilla is not better addressing this.

jscher2000
  • Top 10 Contributor
2365 solutions 20934 answers

Hi cybervigilante and NotionCommotion, just to be clear, Firefox tries to render web pages as designed including linked-in content from other servers.

There are an abundance of add-ons to alter how pages load, including ones that target ads (e.g., AdBlock Plus), scripts (e.g., NoScript and YesScript), and ones that target sites by URL (e.g., BlockSite). Many of these extensions have been developed and refined for many years. It's unlikely that their functionality will be subsumed into Firefox itself.

NotionCommotion 0 solutions 6 answers

Hi jscher2000,

I still find it odd how a FireFox plugin or extention can not only cause FireFox to lockup, but cause the entire operating system to lockup. Regardless, I want it to stop.

I currently have extensions: Firebug, Garmin, HtmlValidator, HttpWatch, Search Everwhere, SQL Inject Me, View Cookies, XSS Me. I also have Norton Toolbar, Norton Vulnerability, and Skype, but these three are disabled. I also have plugins: Adobe, Garmin, Google Update, HttpWatch, Java Deployment, Java Platform, Photo Gallery, and Shockwave.

Will removing these cure the problem? I use FireBug fairly open, but probably can live without the rest.

Thanks

jscher2000
  • Top 10 Contributor
2365 solutions 20934 answers

Hi NotionCommotion, there was/is an issue with Firebug and Firefox 21: the new script debugger in Firefox 21 seemed to slow page loads to a crawl if Firebug was running for the same page. However, it sounds as though your issue pre-dated that (you said "for about a year now").

If there are extensions you don't need for 24 hours, I would try running with those disabled and see whether it helps.

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Plugins usually are not active unless there is content in a page that uses them, so those are seldom the problem, and if they were, you would expect repeatable problems hitting the same URL, not random problems.

The times I see Windows effectively locked up by Firefox are when I choose "Forget this site" from the history list, or clear the cache. Not sure whether it's a CPU or a disk issue, but no work can get done for a few minutes. (Otherwise, if Firefox needs extra time to load a page, other applications seem fine.) Do you notice high CPU utilization or a lot of disk churn during the time that Windows is not responsive?

cybervigilante 0 solutions 12 answers

No, I didn't say jquery was the problem. I said it's the most common loader, but it's short and I haven't seen it freeze FF. It's Other things that freeze - mostly huge ads that load in the background, some even with video or Flash, analytics, and cdn sites which feed fonts and images, and that are overloaded. FF waits for them to load and freezes you in the meantime. If you never let them load by going to: C:\Windows\System32\drivers\etc and editing the hosts file

When FF freezes just look at the lower left, and see what site is freezing it. Some of my first entries, from crapsites, are:

127.0.0.1 bestofmedia.com 127.0.0.1 mediacdn.disqus.com 127.0.0.1 rubiconproject.com 127.0.0.1 proplayerupdate.com

If the url can't even be resolved, FF doesn't try to load the background site in the first place, and it doesn't freeze. It's just a slow process of blocking the rat sites, one by one. There are other types of ad and script blockers, but they 're tricky and often have unwanted side-effects. This is simple.

Of course, if you block a site that has 'font' in the name, and no longer see those Kewl fonts, you'll know why ;') I don't think any of these background sites are essential. A webmaster would have to be nuts to freeze his own site waiting for a background site. It's FF that's doing it. And you might not see the loading delay at all if you're on a real fast connection. But I'm not.

Wonderful windows may make it hard to find etc From an editor. Allow yourself to view all files in Folder Options, find etc with the Windows Explorer, Then right click to edit it. You have to run the editing program as Administrator in Win 7.

cybervigilante 0 solutions 12 answers

Blocking by URL would be the best, IMHO. It's what I do with the hosts file, but that might be simpler for those who don't want to mess with hosts. The other types of blockers are trickier and I've had trouble with them. It's best to simply keep an eye out for stalling sites in the lower left corner and block them, one by one. The automated stuff may be easier but it also seems to do stuff you may not want. Setting adblock to block what you want and pass what you don't want blocked, can be tricky, and is an ongoing task as you find it blocking something you want ;') And I really don't want to turn off javascript with a script blocker.

NotionCommotion 0 solutions 6 answers

Hi jscher2000 and Cybervigilante,

I will try your workarounds (remove extensions, block URLs, etc), but I don't think these "fixes" are in Mozilla's best long term interest.

Yes, maybe the evil websites cause FireFox to hang up. Or maybe Gates and Ballmer are the real sinister ones, and have designed Windows 7 to crash when we use FF. But it is up to Mozilla to make their product not vulnerable to these issues. I definitely prefer FireFox, but am getting tired of dealing this issue, and hope the leadership at Mozilla know users like myself's concerns.

DonGateley 1 solutions 28 answers

When I see these extended length "Not responding" states (eventually requiring restart and frequently reboot) there is no CPU or disk activity and memory is not more than 80% used (out of 8GB.) I'd call that a bug.

I always, and only, get it some significant time after a full backup with Acronis True Image has completed. It seems also to be stimulated by other machines on my network doing full backups. The FF stuck state always, and I mean always, occurs well after backups are complete and after a half hour or more normal interaction with FF. That is utterly bizarre. Nothing that I use other than FF shows this behavior.

The state used to occur with a lot more frequency but now only subsequent to Acronis full backups.

(FWIW I just updated to 22.0 and (using both Memory Fox and UnloadTab) I have never seen FF memory usage so low. It's working set is in the 800MB range with lots of windows and tabs. Curious to see if the problem we are talking about here is ameliorated. 22.0 seems a whole lot snappier in general.)

NotionCommotion 0 solutions 6 answers

Just noticed that I have 0 solutions and 5 (or 6 after I write this) answers.

I've never experienced this problem with IE, but then you using IE which is a Hell in itself. I have also never experienced this symtom when running FF on my CentOS laptop, and as such recommend changing your operating system to Linux.

PS. Mozilla still needs to address this because too many people use Windows.

cybervigilante 0 solutions 12 answers

Since more and more websites are doing background loading of more and more crap, even if you don't use FF, it's probably a good idea to start blocking all that. It used to be they might load jquery (which is no problem) and maybe a webfont, but it's getting way out of hand. Webmasters are throwing in everything but the kitchen sink. And what in hell is with using spidery light gray font on a gray background, which seems to be a fad. Do they think we all have microscopic vision like Superman? All these web books talk about usability and visibility, but the all-is-gray-and-black design-fad totally ignores that.

Question owner

Volker2 Hi, I now do have a new Windows 8 computer and Firefox does function OK. I wanted to write to you but then my computer got defective. My old computer and computer monitor were 4 and a half years old. With my old Vista computer, I had my computer monitor screen (screen saver), change to the color black after 20 minutes ( switched off). When my computer monitor screen changed to the color black after 20 minutes of not touching the mouse or keyboard, the Firefox browser crashed exactly at this time each time without exception. The other time when it crashed very often was, when I had just started the Firefox browser. At the end of 2012, Microsoft had sent me an update for the driver of my graphics card of my computer monitor. This had caused many crashes of my computer. So I changed the driver of my graphics card to the old driver of my graphics card and blocked any Microsoft updates to the graphics card driver. Microsoft also wrote that the driver was important. But my computer worked fine without the graphics card updates from Microsoft. Except the Firefox browser crashed very often with TV and videos. But now I am using a new Windows 8 computer on which the Firefox browser does work very well.

DonGateley 1 solutions 28 answers

That is very useful information. Who'd have thought the graphics driver would be the source of Firefox issues.

I now have some (harmless) issues where FF screens start flashing and blinking sometimes and I'll bet the problem is with my driver. (Nvidia, whose updates never install and about which they have no concern whatsoever.)

capilot20 0 solutions 1 answers

I have the same problem and have spent endless hours, days and months looking for and TRYING many different "suggestions". NONE have worked.

I just found two things that appear to help. I noticed some site pages apparently reload or refresh frequently, likely from some Flash "crap". Since I often have many windows open and dozens of tabs, if several tabs are from the same site, it can accumulate. Today Firefox would freeze for 2 - 3 seconds and only un-freeze for a second before freezing again. I couldn't even close pages.

I eventually got some of the pages closed that appeared to be causing Firefox to refresh CONSTANTLY, again I believe from Flash "crap".

Because I have a high end PC with an EIGHT core CPU, I do tend to keep a lot of windows open. I found a post on another site that I also think will help.

It suggest that you go into the address bar, type "about:config". Then in the search bar, just under the address bar, type in "browser.sessionstore.max_concurrent_tabs" and set to 0 ("Zero"). I am using Windows 8 and did not have that item listed.

Next, again in "about:config", type in "browser.sessionstore.interval" and set this to a HIGH number. The article suggests a value of 600,000 (milliseconds). The normal value is between 10,000 or 15,000. Making it a much higher number prevents pages from refreshing constantly.

Between finding the offending sites running Flash "crap", eventually, finally getting them closed AND changing my "browser.sessionstore.interval" level to 600,000, this CONSTANT, every second or two FREEZE has at last stopped.

I know there are tons of suggestions and as well many different reasons for Firefox to behave badly. For me, I had tried for over 6 months to find an answer that actually worked, NONE did till this.

I hope for anyone else "at the end of their rope" and who loves Firefox otherwise, that this might help.

The link for the site and suggestion is "http://www.eonlinegratis.com/2013/why-does-firefox-cause-high-cpu-usage-spikes-every-few-seconds/".

The article also has a link to what "sessionstore" is at: "http://helgeklein.com/blog/2010/12/solved-firefox-freezes-every-10-seconds-scrolling-is-jumpy/"

Good Luck

jscher2000
  • Top 10 Contributor
2365 solutions 20934 answers

Hi capilot20, extending the period between session saves should help some people. Just so that everyone understands the math:

  • browser.sessionstore.interval (milliseconds)

15000 milliseconds /1000 = 15 seconds (default)

60000 milliseconds /1000 = 60 seconds /60 = 1 minute

600000 milliseconds /1000 = 600 seconds /60 = 10 minutes

If Firefox isn't crashy, losing track of any tabs changes in the past couple minutes probably isn't a big deal. Not sure everyone will be comfortable with 10 minutes, but each can choose their own.

  • browser.sessionstore.max_concurrent_tabs

This preference no longer is used. Instead, Firefox will load tabs only on demand after a session restore (when you access them). To change this, use the 5th checkbox on this tab:

orange Firefox button (or Tools menu) > Options > Tabs > "Don't load tabs until selected"

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96852 answers

If restore_on_demand is set, pinned tabs are restored on startup by default.
When restore_on_demand is set to true, the restore_pinned_tabs_on_demand pref overrides that behavior, and pinned tabs will only be restored when they are focused.
Firefox loads a maximum of three tabs at a time and this value is hard coded (MAX_CONCURRENT_TAB_RESTORES = 3) and cannot be changed anymore via the browser.sessionstore.max_concurrent_tabs pref.

cybervigilante 0 solutions 12 answers

Besides background loading of CDNs, images, videos, ads, fonts, and scripts sometimes slowing FF to a crawl, I've found that a Twitter button on top of a site often makes it stall, if Twitter is jammed up. Not sure how you'd fix that if you like Twitter. I have Twitter in my hosts file. I got tired of squeezing my thoughts into 140 chars, anyway ;')