X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My Home Page does not load when Firefox starts up

Posted

Since the update to Firfox 18, my home page does not load on startup. I Windows 7 Please advise

Chosen solution

Brilliant, thank you it was an extension that was added without my realising it had been done - for anyone else with this problem, the extension was for Grammarly - grammar checker!

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • BlackBerry WebSL Browser Plug-In
  • WildTangent Games App V2 Presence Detector
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • WinZip Courier Plugin for Mozilla Firefox
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • npapicomadapter
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
415 solutions 4908 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Chosen Solution

Brilliant, thank you it was an extension that was added without my realising it had been done - for anyone else with this problem, the extension was for Grammarly - grammar checker!

wyoangel 0 solutions 1 answers

Okay this is fine and dandy if you are not using grammarly...However, I use this website all the time for school and if I enable the addon then my pages don't load upon opening firefox. So additional suggestions?? Every time firefox updates I have the same issue.

Eddy 0 solutions 1 answers

I too had a very similar issue. Anytime I went to use Firefox (v21) either through a direct click on the FF icon, or through a web link in another application I would only get a blank tab/window on start-up. If FF was already running and I clicked on a web link in an application it would then load the corresponding web link. After disabling all addon's I started the pain staking task of trouble shooting each one by enabling it and restarting FF. Turns out the the Grammarly copy/paste support (2.0) addon was the culprit. In the future I will only enable it if I need it. Hope this helps someone.