Firefox not showing Java 7 u11 plugin after install on system, fixes not working.

I recently realized that my installation of Java was out of date. Apparently Firefox was automatically disabling the Java plugin due to it being unsafe or something like that.

Anyway I went through my control panel > programs and features and removed ALL Java products before doing a fresh install of Java 7 u11. The install went fine but the plugin is not displaying in the firefox plugins area.

After going to a few different websites that require Java, including the "do I have java?" test applet, I am being told by Firefox that I need the Java 7 u11 plugin. When I try to install it gives me a failure error once it's done downloading and asks me to install manually. This manual install is just installing it on my system again.

I have tried deleting that pluginreg.dat file which did not work. I have tried uninstalling and reinstalling Java which did not work. This "JavaFX" program does not exist on my system so removing it wasn't an option.

According to this link...

...I can create a fix.reg file and paste the linked contents in to it and run that to perform a registry fix. I tried both the 64bit and 32bit versions and neither seemed to have worked.

My system/OS is 64bit and I believe my Firefox install is 32bit. I must be doing something wrong here as none of the above solutions have worked for me so far.

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • owner