X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 18.1 runs realy buggy all videos.... but in safari they work..

Posted

Open youtube ands just freezes out or runs realy lazy... in safari works fine...

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Install Detector for BlueStacks App Player
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Näyttää Java-sovelman sisällön tai paikanvaraajan, jos Javaa ei ole asennettu.
  • QuickTime-liitännäisen avulla voit katsella monenlaista verkkosivuilla olevaa multimediasisältöä. Lisätietoja saat QuickTimen verkkosivustolta.
  • DivX Plus Web Player version 2.2.1.2
  • DivX VOD Helper Plug-in
  • 5.1.10411.0
  • Facebook Video Calling by Skype

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
414 solutions 4905 answers

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

iamjayakumars
  • Top 10 Contributor
414 solutions 4905 answers

Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!