X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I have windows 2000 prof. and i am having problems with my firefox browser, freeze-ups etc. i have explorer 6 as my default browser. Can you help me?

Posted

Unable to upgrade Explorer 6, as well as firefox. Computer tells me it can not find an access point or path can not be found. System: Compaq Preserio,Microsoft 2000 5.00.2195. I continue to have issues with freeze-up, downloads, web browsing, e-mail browsing etc. My web co. is Juno and they use Explorer as their default browse. I have contacted them many times with no luck. Is the anything you can help me with here. I have a limited budget, for I am unemployed and need this computer to help me find a job. Can you please help me with these issues?

                                                                       Sincerely, Ernest Caron

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 8.3.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

If you are are experiencing the same issue downloading something else then it is not a Firefox issue. Also, please have a look at the following as copied from another contributor.

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

   Do NOT click the Reset button on the Safe mode start window or otherwise make changes. 
James
  • Top 25 Contributor
  • Moderator
437 solutions 3159 answers

And before anybody suggest he use the current release, the OP cannot as the Firefox 12.0 was the last to support Win2000 as one needed WinXP or newer for Firefox 13.0

.
.

Edit: it was late.

Modified by James

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24406 answers

The last version of Firefox which supported Windows 2000 SP4 was Firefox 12.0. You can run a Firefox 13.0+ version by installing special "service packs" as described in this MozillaZine Builds support thread.

http://forums.mozillazine.org/viewtopic.php?f=23&t=2482475&hilit=Windows+2000

You'll need to read thru all the pages in that thread to get the download links for those "service packs".