X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why is there no default search engine in search box ?

Posted

I have reset Firefox but the searchbox at the top right hand side has no default search engine or any others so I cannot do a search.

Chosen solution

Since this issue happened at work I had to get IT to do this. He said he'd never seen this issue before. It worked so Thank You!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • SiteAdvisor
  • McAfee Virtual Technician plugin
  • McAfee MSC FF plugin DLL
  • Google Update
  • 5.1.10411.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • NPWLPG
  • ScorchPlugin
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

Try to install https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Question owner

Thank you for a very quick reply. Shortly after I asked the question I closed Firefox then opened it up again and this time all the search engines mysteriously appeared ! So problem solved ! I'll keep the link you sent me in case it happens again.

booklover777 1 solutions 3 answers

This didn't work for me. Is there any other way to restore search from the address bar or search engine box?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

You can check if you still have the XML files of the default search engines including Google in the searchplugins folder in Firefox program folder.

If not then you need to reinstall Firefox.

You can find the latest Firefox 20.0.x release in all languages and for all Operating Systems here:

You can try to delete the search.json file and a possible search.sqlite file in the Firefox profile folder.

Firefox will rebuild the search.json file from the default search engines in the searchplugins folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
booklover777 1 solutions 3 answers

Neither the search.json or search.sqlite files exist in either my Profile folder or the Program Files folders. I don't even have a searchplugins folder. I reinstalled and still don't have those files. Anything else I can do to recover those files?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


booklover777 1 solutions 3 answers

Chosen Solution

Since this issue happened at work I had to get IT to do this. He said he'd never seen this issue before. It worked so Thank You!