X
Tap here to go to the mobile version of the site.

Support Forum

youtube click_to_play

Posted

I hate getting pop-ups, videos and adverts in my face as well as eating up my monthly broadband quota as I surf the web looking for information, so in FireFox I had set about:config -> plugins.click_to_play = true

That was working fine until recently. Now I see youtube somehow started bypass this setting of mine and shove the video at me anyway in spite of the message that it needs a plugin!

I note youtube equally bypass the 'ActiveX Filtering' in Internet Explorer 10. IMO there is no point having these options and settings if unscrupulous site operators can bypass them.

I presume youtube are abusing HTML 5 capabilities to achieve this effect and so I want to know if we can still disable active content or are going to be completely at the mercy of every site we visit in the future. :(

I hate getting pop-ups, videos and adverts in my face as well as eating up my monthly broadband quota as I surf the web looking for information, so in FireFox I had set about:config -> plugins.click_to_play = true That was working fine until recently. Now I see youtube somehow started bypass this setting of mine and shove the video at me anyway in spite of the message that it needs a plugin! I note youtube equally bypass the 'ActiveX Filtering' in Internet Explorer 10. IMO there is no point having these options and settings if unscrupulous site operators can bypass them. I presume youtube are abusing HTML 5 capabilities to achieve this effect and so I want to know if we can still disable active content or are going to be completely at the mercy of every site we visit in the future. :(

Modified by perduta

Chosen solution

I seem to have fixed the problem as follows:

From the FireFox Help menu -> troubleshooting click in 'reset to default state' and I also uninstalled adobe flash player and reinstalled a fresh copy. Then I set up the preferences again.

I'm not sure what the problem was, but I noticed Flash player plugin keeps asking to be enabled on individual sites now and I suspect I may have clicked that at some stage and this allows it to make inconsistent exceptions that confuse the click-to-play settings.

Read this answer in context 11

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12117 solutions 112638 answers

Helpful Reply

Did you enter the HTML5 test on YouTube?

You can also try to set the media.autoplay.enabled pref to falser on the about:config page.

Did you enter the HTML5 test on YouTube? * http://www.youtube.com/html5/ You can also try to set the media.autoplay.enabled pref to falser on the <b>about:config</b> page.

Question owner

Ah, no... I could have sworn I opted out ... but thanks for that link because something somehow appears to have opted me back in! :O It is a bit worrying if this is going to happen when their html 5 goes live, but opting out again seems to have fixed the problem for the time being. Just to be on the safe side I also switched off media.autoplay.enabled as you suggested :)

edit: update see below.

Ah, no... I could have sworn I opted out ... but thanks for that link because something somehow appears to have opted me back in! :O It is a bit worrying if this is going to happen when their html 5 goes live, but opting out again seems to have fixed the problem for the time being. Just to be on the safe side I also switched off media.autoplay.enabled as you suggested :) edit: update see below.

Modified by perduta

Question owner

... however opting out again is only a partial solution: I restarted ForeFox then SOME youtubes are click to play but others play anyway! For instance: watch?v=c5NL76BXauY is blocked until I click but watch?v=M4vqr3_ROIk is NOT and forces itself onto the screen even though it says a plug in is needed?!

... however opting out again is only a partial solution: I restarted ForeFox then SOME youtubes are click to play but others play anyway! For instance: watch?v=c5NL76BXauY is blocked until I click but watch?v=M4vqr3_ROIk is NOT and forces itself onto the screen even though it says a plug in is needed?!
cor-el
  • Top 10 Contributor
  • Moderator
12117 solutions 112638 answers

You can add &html5=1 or &html5=0 to a video link to try to force a specific version.

You can add &html5=1 or &html5=0 to a video link to try to force a specific version.

Question owner

Thanks, I did try that but it makes no difference: The video plays regardless. Maybe it has nothing to do with html5. Internet explorer can't block it either. It is a problem when our monthly data plan is squandered on video we don't want to watch :(

Thanks, I did try that but it makes no difference: The video plays regardless. Maybe it has nothing to do with html5. Internet explorer can't block it either. It is a problem when our monthly data plan is squandered on video we don't want to watch :(
cor-el
  • Top 10 Contributor
  • Moderator
12117 solutions 112638 answers
Try: * https://addons.mozilla.org/firefox/addon/stop-youtube-autoplay/

Question owner

I tried that latest version of the addon/stop-youtube-autoplay but it doesn't seem to make any difference at all... Even stranger when I went back to about:config and disabled plugins.click_to_play and enabled media.autoplay it also makes no difference. It still says I need a plug in but continues to play anyway on some videos.

I tried that latest version of the addon/stop-youtube-autoplay but it doesn't seem to make any difference at all... Even stranger when I went back to about:config and disabled plugins.click_to_play and enabled media.autoplay it also makes no difference. It still says I need a plug in but continues to play anyway on some videos.

Chosen Solution

I seem to have fixed the problem as follows:

From the FireFox Help menu -> troubleshooting click in 'reset to default state' and I also uninstalled adobe flash player and reinstalled a fresh copy. Then I set up the preferences again.

I'm not sure what the problem was, but I noticed Flash player plugin keeps asking to be enabled on individual sites now and I suspect I may have clicked that at some stage and this allows it to make inconsistent exceptions that confuse the click-to-play settings.

I seem to have fixed the problem as follows: From the FireFox Help menu -> troubleshooting click in 'reset to default state' and I also uninstalled adobe flash player and reinstalled a fresh copy. Then I set up the preferences again. I'm not sure what the problem was, but I noticed Flash player plugin keeps asking to be enabled on individual sites now and I suspect I may have clicked that at some stage and this allows it to make inconsistent exceptions that confuse the click-to-play settings.