Question

cant get update to work on 3.6.8.

I have gust upgraded my old imac os power pc to current 10.8.2 and cant get foxfire to update. set on auto update nothing happens

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • solution