X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Page does not render properly in FF 18.0.1 for Mac but on everyone else's it does

Posted

Please check this page out. http://windhamtaxpayers.org/windham/ On everyone else's 18.0.1 FF for Mac, the sidebar lines up fine, the blog style articles listed on the 3/4 page to the left.

But on mine, no matter what I do, the sidebar is all jumbled!

It can't be the theme files, as they are looking at the same ones. It has to be my browser. It looks fine in Safari.

WHAT IS WRONG? If you don't see it as I do I can take a screen shot.

Chosen solution

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10516.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

If you have increased the minimum font size then try the default setting "none" in case the current setting is causing problems.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow websites to choose their fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with overlapping text.

Question owner

Certainly after clearing my cache there MUST be a file that has corrupted the process and that I can trash to fix this???

This is driving me off the cliff, please!

Question owner

Yes I already had those settings.

Question owner

Yes I did that as well...

Question owner

I have NO extensions and using the default theme.

Question owner

Did safe mode, have no extensions, using default theme, no minimum font size, let sites use fonts, etc. Cleared cache 3 times...

When you visit the site you probably see it normally... a nice right hand sidebar with the usual WP items, and the test posts on the front, one after the other on the left hand 2/3 of the page. Looks great in Safari...

I don't usually tamper with my browser so I am not sure what files on it could be corrupted that would cause this rendering problem. The person for whom I am making the site has the same computer (MAC) and he looked at it in both browsers and his looks fine!

I use FF mostly so it bothers me that I would have to switch to Safari just to work on this site... it's technically wrong and I want to fix it.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Chosen Solution

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Profiles? Now that's a new one on me. I wasn't aware I logged into a browser but I will check it.

BUT I guess I won't have to mess with that, because what you just told me fixed it!

I knew about the about: whatever but had no idea how to reach it again...

THANK YOU!!!!!