Question

"maxVersion" of install.rdf not taken into account with Firefox 18.

Hello,

I got something really strange with my extension (which install a NPAPI plugin). I was used to update maxVersion property of the install.rdf every time a new major version of Firefox was released.

Today, I wanted to give a try of installing the extension with a too lower maxVersion value. I was extremely surprised to see that Firefox accepted it. I was able to drop the maxVersion value down to "4.*" (lesser it says that Firefox is not compatible).

I got it under Fedora and Windows.

Here is my install.rdf:

<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"

    xmlns:em="http://www.mozilla.org/2004/em-rdf#">
 <Description about="urn:mozilla:install-manifest">
   1.2.0.11
   ctviewer@camtrace.com
   2
   CamTrace Viewer
   Displays CamTrace video streams.
   
     <Description>
   <em:locale>fr-fr
   CamTrace Viewer  
   Affiche les flux video CamTrace.
     </Description>
   </em:localized>
   Camtrace S.A.S.
   http://www.camtrace.com/
   chrome://ctviewer/content/camtrace.png
   true
   
   
   <Description>
       <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}
       1.5
       4.*
   </Description>
   </em:targetApplication>
 </Description>

</RDF>

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • solution