X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't open PDF documents

Posted

When I click on a PDF, a new tab opens. It gives me the option to open the document directly or save it--this is what I have preferences set to do. However, when I try either of those options nothing happens. It only opens a new blank tab. My specifications are below. I've run all the relevant software updates.

System: OS X 10.8.2

Adobe Reader: 10.1.5

Firefox: 18.0.1

I've seen this problem on other posts and I've done some searching on the web. I've tried the solutions that have been provided and worked for other people, however I noted that they were running older versions of some of the software, etc. Interestingly, I CAN open PDFs that come to me or that I send through Gmail.

I have done the following based on the advice I've seen:

Cleared my downloads list

Tried disabling the Adobe NPAPI Plug-In

In my Firefox preferences: I have set PDF documents to be open by Adobe. I also tried it with Preview. Neither of them worked.

I appreciate any help you can offer.

Modified by kylevmorris

Chosen solution

This what worked very well for me. In case your application preferences file has become corrupted, you could try renaming or deleting it. Help > Troubleshooting Information > "Show Folder" The file is named mimeTypes.rdf and if you rename or delete it, it should be regenerated with default the next time you restart Firefox.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Version 3.10.2.10212
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

jscher2000
  • Top 10 Contributor
2363 solutions 20910 answers

Hi kylevmorris, the mimeTypes.rdf starts out with a limited set of pre-defined application handlers. This can be modified by plugins, data from the Windows registry, changes you make in Application options (Options>Applications or Preferences>Application), and choices you make in the Open/Save/Cancel dialog.

Because there's no supervisor in Firefox making sure the file is completely coherent, it sometimes becomes, for lack of a better phrase, messed up. When you rename or delete the file (the file in your active personal settings folder accessible using Help > Troubleshooting Information > Show Folder button), you restart the process of building the list of application handlers. Everything should be good unless/until it becomes messed up again.

(Note that the mimeTypes.rdf is a text file that you could try editing by hand, but due to its poorly documented structure, and Firefox's ability to rebuild it, it's usually easier to just rename or delete it when there are problems.)

jscher2000
  • Top 10 Contributor
2363 solutions 20910 answers

Helpful Reply

To all: please note that starting in Firefox 19, the built-in PDF Viewer may be activated in place of the application that previously handled PDFs.

To manually change this setting, you can try the steps described in this article: View PDF files in Firefox without downloading them". In brief:

(1) Open your Firefox Options/Preferences dialog

  • On Windows, click the orange Firefox button or click the Tools menu, then choose Options.
  • On Mac, click the Firefox menu then Preferences.
  • On Linux, click the Edit menu then Preferences.

(2) Click Applications and pause while the list is displayed. Type pdf in the search box to filter the list.

(3) Click the drop-down control to the right of "Portable Document Format (PDF)" to change it from "Preview in Firefox" to your preferred handler for PDFs. For example, if you prefer to open PDFs in a Firefox tab using Adobe's plugin, choose "Use Adobe Acrobat (in Firefox)".

(4) Click OK to save your change and close the Options/Preferences dialog.

mjkessler5 0 solutions 2 answers

I have a solution. Thanks to all of your feedback I did the following: 1. Uninstalled Adobe Reader (apparently not necessary) 2. Uninstalled Firefox (preserved personal settings - bad choice) 3. Downloaded Firefox from http://www.mozilla.org/en-US/firefox/new/ 4. Accessed PDF - still failing 5. Changed Applications Actions options - no change 6. Uninstalled Firefox (removing personal settings - good choice) 7. Reinstalled Firefox (imported bookmarks, etc. from Chrome) 8. Accessed PDF - now works (note Adobe Reader not yet reinstalled, using Preview in Firefox) 9. Tested Applications Actions options - now working 10. Reinstalled Adobe Reader 11. Tested Applications Actions option to use Adobe Reader - works 12. Reset Applications Actions option to use Preview in Firefox) - works

Modified by mjkessler5

Huvotnl 0 solutions 7 answers

Super !

jscher2000
  • Top 10 Contributor
2363 solutions 20910 answers

Hi mjkessler5, that sounds like an ordeal. Next time (hopefully there won't be a next time), instead of doing an uninstall/reinstall and removing all settings, try using the Reset feature first: Reset Firefox – easily fix most problems. This preserves many settings that usually aren't implicated in functional problems (for example, bookmarks) while giving you a fresh start on other settings.