X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't open PDF documents

Posted

When I click on a PDF, a new tab opens. It gives me the option to open the document directly or save it--this is what I have preferences set to do. However, when I try either of those options nothing happens. It only opens a new blank tab. My specifications are below. I've run all the relevant software updates.

System: OS X 10.8.2

Adobe Reader: 10.1.5

Firefox: 18.0.1

I've seen this problem on other posts and I've done some searching on the web. I've tried the solutions that have been provided and worked for other people, however I noted that they were running older versions of some of the software, etc. Interestingly, I CAN open PDFs that come to me or that I send through Gmail.

I have done the following based on the advice I've seen:

Cleared my downloads list

Tried disabling the Adobe NPAPI Plug-In

In my Firefox preferences: I have set PDF documents to be open by Adobe. I also tried it with Preview. Neither of them worked.

I appreciate any help you can offer.

Modified by kylevmorris

Chosen solution

This what worked very well for me. In case your application preferences file has become corrupted, you could try renaming or deleting it. Help > Troubleshooting Information > "Show Folder" The file is named mimeTypes.rdf and if you rename or delete it, it should be regenerated with default the next time you restart Firefox.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Version 3.10.2.10212
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

I think disabling the plugin is the best thing to do. That should avoid the blank tab because Firefox would not try to render the PDF internally. If you do that, does anything change?

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

In case your application preferences file has become corrupted, you could try renaming or deleting it.

Help > Troubleshooting Information > "Show Folder"

The file is named mimeTypes.rdf and if you rename or delete it, it should be regenerated with default the next time you restart Firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Helpful Reply

The Adobe Reader plugin may not be working properly on Mac.

Disable the Adobe Reader plugin in Firefox (Tools > Add-ons > Plugins) and use the external Adobe Reader application or Preview application instead.

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader

PDF files may also be found under another entry like Portable document.

Huvotnl 0 solutions 7 answers

I HAVE THE SAME PROBLEM WITH

System: OS X 10.6.8

Adobe Reader: 10.1.5

Firefox: 18.0.1

IS THERE A SOLUTION

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi Huvotnl, have you disabled the Adobe Acrobat plugin here:

Tools > Add-ons > Plugins category

Huvotnl 0 solutions 7 answers

Yes I did ! I have event deleted extensions.

Question owner

I have disabled the plug-in and told the system to use the Adobe application to open PDFs...nothing changed.

If I delete the file you are talking about, will I lose my bookmarks or anything like that???

Modified by kylevmorris

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

The mimeTypes.rdf file does not contain any bookmarks or personal data. If you are concerned about potential data loss, please make a backup of the contents of your personal settings (Firefox profile) folder before making any deletions.

rmscown 0 solutions 1 answers

In Preferences--Applications it seems as though the default for some items is "always ask" which doesn't happen! I changed "Preview Document (application/pdf)" from "always ask" to "Use Adobe Reader". I also changed "Preview Document (x-unknown/pdf)" from "always ask" to "Save File". Now the desired content opens in a new window & is downloaded to my desktop (my preference). I use a Mac & am not a computer whiz. This seems like a really stupid problem related to the newest version of Firefox.

ernie06896 1 solutions 2 answers

This worked 4 me. Took me a while to find "show folder" that was right in front of me. Thank you

mjkessler5 0 solutions 2 answers

I have the same PDF problem which also has recently appeared. I am using Windows 7 on a 64 bit PC. I have tried multiple options/applications action settings for PDF and none appear to take effect. IE and Chrome work fine.

Question owner

I appreciate all the responses and help---but none have worked for me either. If anyone finds success, let me know. For the time being I've just been going to Safari anytime I need to open a PDF.

Huvotnl 0 solutions 7 answers

Hello

It works now!

MAC 10.6.8 Firefox 19.0 Adobe 11.0.0 Install extension PDF 3 0 0 2

Remove everything, reinstall everything

Cross my fingers

Question owner

Huvotnl,

Can you clarify? Was there an update released? And what do you mean by "remove everything?" What does that specifically entail?

Thanks,

Kyle

Huvotnl 0 solutions 7 answers

Remove Adobe Remove the extension Update Firefox to 19.0 Reload Adobe 11.0 Reload the extension PDF 3 0 0 2

Question owner

Ok, what is extension PDF 3002? I think I understand the rest to mean, Update Firefox and delete Adobe the go back and redownload it. Yes?

Huvotnl 0 solutions 7 answers

On Firefox :

Toll Module Extension type PDF in search and you will see PDF Download 3 0 0 2 Dowload this extension

ernie06896 1 solutions 2 answers

Chosen Solution

This what worked very well for me. In case your application preferences file has become corrupted, you could try renaming or deleting it. Help > Troubleshooting Information > "Show Folder" The file is named mimeTypes.rdf and if you rename or delete it, it should be regenerated with default the next time you restart Firefox.

Question owner

Ernie,

That did it! Well some combination of what you said and all the updating stuff. I did try the PDF extension that Huvotnl suggested b/f doing what you suggested, but it didn't work. Anyway, that's months of frustration every time I wanted to download something now resolved.

Now, can you help me understand WHY that worked? How does renaming something change what's inside the file? Also, how did the file get corrupt? Is that any indication of a virus or some other larger problem I should be worried about? Not a tech guy here.

Also, I'm presuming that none of my other info, most importantly bookmarks, were lost, etc. I checked and they all seem to be there in the list. I just like to understand stuff.

Kyle

Huvotnl 0 solutions 7 answers

Also

Not all sites will work by all mean being able to download PDF file

With some you will have to download manually the file either save or open.

Please use save then open the file. This work for me.

I hope you understand