X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 18 slowing down over time

Posted

I'm running Firefox 18.0.1 under Windows 7, all updates current, on a Dell M6700 I7, 2.77Ghz, 8Gig ram. When I first start Firefox, it runs fine. After about 30min, it gets slow. the bookmark memu takes several seconds to draw, sites take several seconds to load/reload. This was not a problem with the same version under Windows XP using even more plugins and extensions.

If I quit and restart Firefox, it runs fast for awhile, then slows down again.

I've tried turning off most extensions and plugins and the problem does not change.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

Which security software (firewall, anti-virus) do you have?

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

I tired shutting off all security software and disabled the firewall with no effect. I didn't really expect any change since quiting and restarting Firefox temporarily solves the problem. This has the feel of a memory leak.

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

Did you try a new clean profile?

Question owner

Yes, I created a new user acct to make sure it was clean. Watching memory with the Resource Monitor is showing memory for all four categories going up over time. At launch they are 242812, 228056, 52120, 175928 After about 30min of browsing: 580996, 598384, 84984, 513400

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

You can check the about:memory page and try to click the button at the bottom to minimize the memory usage to see if that helps.

trester 0 solutions 4 answers

Same problem here. Tried the new profile, no addons, mimimize memory but the problem continues.

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

Helpful Reply

Does it help if you run Firefox in Safe mode?

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled

Try to disable hardware acceleration in Firefox.

trester 0 solutions 4 answers

A lot better with the hardware accelaration disabled! For the record my laptop uses Nvidia Optimus with a Nvidia NVS 4200m (Driver 9.18.13.697) for graphic intensive apps and an Intel HD (8.15.10.2418) for 2D apps.

David W(satdav) 3 solutions 36 answers

Have you tried the following yet

How to make firefox faster

trester 0 solutions 4 answers

Update: After six hours of disabling hardware acceleration, Firefox 18 continues working as fast as 17. Thanks for the tip Cor-el.

trester 0 solutions 4 answers

I updated the drivers Intel HD Graphics 3000 ver. 9.17.10.2867 and Nvidia NVS 4200M ver. 8.17.12.9679 from the DELL support site certified for my laptop. Hardware acceleration turned on and working OK.

kobimaru 0 solutions 1 answers

Helpful Reply

Mozilla support.... The memory usage of Version 18.0.2 is obscene. I am seeing upwards of 1.8GB of memory used by Firefox. This is your code causing this... I did not have the problem on V16, V17 but V18 consumes memory at an alarming rate. Stop asking me to create new profiles, turn off my add ins, throw salt over my shoulder, and hop on one leg to make your code work. Fix it.

Wahoo 0 solutions 2 answers

Using ADD-ons to remove memory leak. Mozilla says to remove add-ons to fix leak. Firefox sucks memory. it always has and always will. Nobody wants to admit it exsists on the Mozilla side must less fix it. Firewalls , etc do not cause the leak. You can remove all your ad-ons and leave firefox open and it will suck memory. Every tab you open drains your memory and continues to climb without opening any more. You can then close all your tabs and Firefox will not release the memory. Just fix it guys, it cant be that difficult

eXalted 0 solutions 4 answers

Exactly the same here. Checked about:memory - FIrefox just doesn't remove the closed tabs from the memory. It reaches over 1.5Gb without any plugins. I have to restart it every hour or less.

Even formatted and installed Windows XP anew and the problem still exists.