X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Yahoo took over firefox

Posted

I had this problem for awhile. I tried EVERYTHING. I reset the link in About:config, deleted the XML file....and every time I fix it bam yahoo squirms it's way back. Nothing seems to be a permanent fix...the only other thing I haven't tried is to take down Yahoo! itself and destroy everything to do with it. I'm hoping Personas has nothing to do with it... That's the only add-on I have. I think. Anyone else have any advice? Or a plan on how to destroy Yahoo? -___-;;

Chosen solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • Windows Activation Technologies Plugin for Mozilla
  • npsitesafety
  • Plugin for Wacom tablets.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

if your manual changes don't 'stick' after a restart of the browser, please look out for any suspicious extensions (like 3rd-party-toolbars or things you have not installed intentionally) presently installed under firefox/tools > addons > extensions or the programs section of the windows control panel and remove those entries.

in case this doesn't solve the issue please try this: go to firefox > help > troubleshooting information > profile folder - "show folder", then a new window will open up. in this window look out for a file named user.js (it might be used to overwrite your custom settings). in case it is present , delete or rename this file and restart firefox afterwards.

Remove a toolbar that has taken over your Firefox search or home page

How to fix preferences that won't save

Question owner

I can't find that file you mentioned. Also the only extension I found was AVG Security and it was disabled.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

ok, then could you specify in which chases yahoo is appearing where you don't want it to be?

another thing to try is to install the search reset addon - it will revert the most common customizations some adware programs do back to the default: https://addons.mozilla.org/firefox/addon/searchreset/

Question owner

It appears as the mini search bar and it takes over as the main search page instead of Google. However it also disguises itself by using the Firefox search page. But when you search something it uses Yahoo instead of Google.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96650 answers

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

If you do not keep changes after a restart then see:

Question owner

Ok I did everything you said and even tried the safe mode even though I don't have any extensions and I know Personas isn't the problem because I had personas WAY before yahoo decided to declare war with me...And guess what...YAHOO still is the default in safe mode....WHAT IN THE NOODLE CUP IS WRONG WITH YAHOO??? The reset option worked for two restarts...but at the third Yahoo came back. I'm starting to think the only way to get rid of the crappy yahoo search bar and mini bar is to declare war with Yahoo and crush them in a duel...I also forgot to mention the "chromeappsstore.sqlite" wasn't in the folder.

Modified by miradobwarrior

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96650 answers

Chosen Solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Omg...Thank you Cor-el! And really thank you everyone for all these posts! It was the profile that was corrupt. I restarted Firefox multiple times to check and Yahoo never came back. Thank god! I'm not even going to bother restoring my old data...in fear Yahoo comes back. I also noticed AVG snuck on board one day...I got rid of it. I have one final question, how does a profile become corrupt? Anyone know?

Question owner

Yahoo came back....

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96650 answers

Did you install any extensions in the new profile?

Also note that some software comes with 'extras' and you always have to make sure to uncheck boxes to install such extra software packages.

Do you have a user.js file in the current profile folder?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

See also:

Question owner

I think...I fixed it...All I did was re-create a new profile but I deleted the two old ones then I restarted Firefox....I don't want to jinx myself but I think that fixed it...And as for extensions no. I'm hoping this is the end of Yahoo's assault on my Firefox.