X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF18 still underlines parts of a correctly spelled word

Posted

This started with FF16 when using Gmail. I've uninstalled FF and reinstalled to no benefit. I'm finding that these partially underlined words get separated when they are included in a response. I work as a book editor, and this is embarrassing when receiving replies from customers. I'm now using FF 18.0.1 and the problem was supposed to be fixed by now. What gives???

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Google Update
  • Garmin Communicator Plug-In 4.0.4.0
  • Garmin Communicator Plug-In 4.0.3.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • iTunes Detector Plug-in
  • ActiveTouch General Plugin Container Version 105
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

You may be seeing this bug:

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)


Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Question owner

1. I have the English (U.S.) dictionary installed and selected.

2. "Check Spelling" in the right-click context menu is check-marked.

3. I have enabled global spell checking under Tools > Options > Advanced : General: Browsing.

4. I clicked the above bug link, but only found 95 comments with no clear solution.

Where do I go from here? Thank you.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

bug 790475 will apparently be fixed in the next firefox 19 release - you could test if it is working as expected with a beta build of firefox: https://www.mozilla.org/firefox/beta/

Question owner

I hope you are right. I was also told that this bug would be fixed in FF 17 and 18, and it has not been fixed yet. I've never had such a frustrating problem with Firefox. If the bug isn't fixed soon, I'll be moving to Chrome. Thanks for your reply.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

you could try it with the beta version of firefox 19 right now...

Question owner

Thanks for the offer, but I don't do beta testing. Too many other bugs often appear (which is why it is called beta).

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96832 answers

The Firefox 19 beta version will become the next Firefox release and patches applied to that release have been 'backed' 12 weeks.
There are two other branches (21.0a1 and 20.0a2) of Firefox development that are, possibly unstable, alpha versions where new code first lands and bubbles down.
Finding and reporting issues in a beta release will allow to fix those issues in time and prevent them from causing serious issues when that becomes the next release.

If you want to test the beta release then you can do that with a separate Firefox Profile Folder as should always be done to avoid corrupting your current default profile for Firefox 18.