Question

Facebook keeps telling me my version of firefox is not up to date and is insecure, but I have already updated 3 times.

Every time I go to facebook, a small box above where I put in my status update says this: You may want to upgrade your browser.

You're using an old version of Firefox that is no longer supported and may be insecure.

To upgrade, open Firefox's Help menu and click Check for Updates...

I have updated 3 times and it still gives this message. its driving me crazy.

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • helpful
  • post
  • post
  • helpful
  • post