X
Tap here to go to the mobile version of the site.

Support Forum

searchsearch bar on start page does not work

Posted

i use the Firefox homepage it has the Firefox symbol and the search bar below it when i try to search using it it does nothing you can type in it but when you push search it does nothing

i use the Firefox homepage it has the Firefox symbol and the search bar below it when i try to search using it it does nothing you can type in it but when you push search it does nothing

Chosen solution

hello, please try the following steps in order to restore the search function on the default homepage:

  1. go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
  2. then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
  3. restart firefox
Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • GEPlugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • 2.1.2
  • HP Product Detection Plugin
  • HP Active Check Plugin
  • 0.70.4
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2823 solutions 13120 answers

Chosen Solution

hello, please try the following steps in order to restore the search function on the default homepage:

  1. go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named chromeappsstore.sqlite.
  2. then enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone - right-click and reset that entry to the default value.
  3. restart firefox
hello, please try the following steps in order to restore the search function on the default homepage: #go to firefox > help > troubleshooting information and click on profile folder/show folder. a windows explorer window should open up - in there delete the file named '''chromeappsstore.sqlite'''. #then enter '''about:config''' into the firefox location bar (confirm the info message in case it shows up) & search for the preference named '''browser.startup.homepage_override.mstone''' - right-click and reset that entry to the default value. #restart firefox

Question owner

it worked thanks very much

it worked thanks very much
Michael Mossman 0 solutions 1 answers

Thanks for the tip ... since I'm using FF on Lubuntu (Linux) the offending file was named webappsstore.sqlite. I deleted that file & reset the browser.startup.homepage_override.mstone entry as mentioned above =)

Thanks for the tip ... since I'm using FF on Lubuntu (Linux) the offending file was named webappsstore.sqlite. I deleted that file & reset the browser.startup.homepage_override.mstone entry as mentioned above =)
cor-el
  • Top 10 Contributor
  • Moderator
12006 solutions 111551 answers

Helpful Reply

Current Firefox versions no longer store the search engine that is used on the about:home page in chromeappsstore.sqlite, but use the default search engine (pref: browser.search.defaultenginename) and the SearchReset extension may be able to fix this.

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise then see:

Current Firefox versions no longer store the search engine that is used on the about:home page in chromeappsstore.sqlite, but use the default search engine (pref: browser.search.defaultenginename) and the SearchReset extension may be able to fix this. Try to use the SearchReset extension to reset some preferences to the default values. *https://addons.mozilla.org/firefox/addon/searchreset/ Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons). If you do not keep changes after a restart or otherwise then see: *http://kb.mozillazine.org/Preferences_not_saved